summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-01-18 19:38:16 -0500
committerAaron Bauman <bman@gentoo.org>2021-01-24 14:03:56 -0500
commit67c2288df8929f41f3eb73f851a507ffb6b06542 (patch)
tree454326064df03f2400f1f809ac42982558c3119f /gui-apps
parentprofiles/package.mask: mask sci-libs/scikits for removal (diff)
downloadgentoo-67c2288df8929f41f3eb73f851a507ffb6b06542.tar.gz
gentoo-67c2288df8929f41f3eb73f851a507ffb6b06542.tar.bz2
gentoo-67c2288df8929f41f3eb73f851a507ffb6b06542.zip
gui-apps/wayland-logout: version bump to 1.4
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wayland-logout/Manifest1
-rw-r--r--gui-apps/wayland-logout/wayland-logout-1.4.ebuild20
-rw-r--r--gui-apps/wayland-logout/wayland-logout-9999.ebuild12
3 files changed, 24 insertions, 9 deletions
diff --git a/gui-apps/wayland-logout/Manifest b/gui-apps/wayland-logout/Manifest
index 207f796a210b..7144704cdd16 100644
--- a/gui-apps/wayland-logout/Manifest
+++ b/gui-apps/wayland-logout/Manifest
@@ -1 +1,2 @@
DIST wayland-logout-1.1.tar.gz 17731 BLAKE2B 179fba23ff885746e6664022a1e427e0a29f59e92b29fdf84807729253d5e3f7d2cea31bd2108f2daeb1bf87fdfceb2ce93fdab4dd3e7a914baeff0102880c84 SHA512 3664c865044e81d7fc41b5888ea1a8669804642b05a518e418c222c90867d38ada4c7f6c5193a251f43498dc9e1a70d4bdf79034569b5add12007523aa011e03
+DIST wayland-logout-1.4.tar.gz 16878 BLAKE2B abc7cd6a6c6916aac97459e733e20cda71068654b30939feac50af94c76db393e94ec2b2df1b3488e0897857ede669e637e5db734c1323db2964fa7bcd821cf6 SHA512 376f39283851478723e3d846055ad76b6ae8b887b487cd98ebcdf87b1d95c3b5de5cad07f2d8921740c4e4102ce988833a9b7ebe662e51654316de9f85daabcf
diff --git a/gui-apps/wayland-logout/wayland-logout-1.4.ebuild b/gui-apps/wayland-logout/wayland-logout-1.4.ebuild
new file mode 100644
index 000000000000..d29f95b176ff
--- /dev/null
+++ b/gui-apps/wayland-logout/wayland-logout-1.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="general logout scripts for wayland compositors"
+HOMEPAGE="https://github.com/soreau/wayland-logout"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/soreau/wayland-logout"
+else
+ SRC_URI="https://github.com/soreau/wayland-logout/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
diff --git a/gui-apps/wayland-logout/wayland-logout-9999.ebuild b/gui-apps/wayland-logout/wayland-logout-9999.ebuild
index 19849dc6704e..d29f95b176ff 100644
--- a/gui-apps/wayland-logout/wayland-logout-9999.ebuild
+++ b/gui-apps/wayland-logout/wayland-logout-9999.ebuild
@@ -1,10 +1,11 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-DESCRIPTION="general logout scripts for wayland compositors"
+inherit meson
+DESCRIPTION="general logout scripts for wayland compositors"
HOMEPAGE="https://github.com/soreau/wayland-logout"
if [[ ${PV} == 9999 ]]; then
@@ -17,10 +18,3 @@ fi
LICENSE="MIT"
SLOT="0"
-
-RDEPEND="sys-process/lsof"
-
-src_install() {
- newbin wayland-logout.sh wayland-logout
- doman wayland-logout.1
-}