summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-25 22:08:39 +0000
committerSam James <sam@gentoo.org>2021-12-25 22:09:50 +0000
commit97985fb97c421b1301b70c750f90051fbcf70bae (patch)
tree9b3b53e0d27ee4b16610fc8616642813a8d7ec27 /gui-apps
parentdev-util/scons: bump to 4.3.0 (diff)
downloadgentoo-97985fb97c421b1301b70c750f90051fbcf70bae.tar.gz
gentoo-97985fb97c421b1301b70c750f90051fbcf70bae.tar.bz2
gentoo-97985fb97c421b1301b70c750f90051fbcf70bae.zip
gui-apps/mako: fix automagic basu usage
Not sure how I missed that before! Fixes: 8f162d2e7717b30d130925a72129d56a4fbd4daa Closes: https://bugs.gentoo.org/783156 Reported-by: Arsen Arsenovic <arsen@aarsen.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/mako/mako-1.6-r3.ebuild (renamed from gui-apps/mako/mako-1.6-r2.ebuild)17
-rw-r--r--gui-apps/mako/mako-9999.ebuild17
2 files changed, 26 insertions, 8 deletions
diff --git a/gui-apps/mako/mako-1.6-r2.ebuild b/gui-apps/mako/mako-1.6-r3.ebuild
index 89b09c2d756e..dc520d5f6127 100644
--- a/gui-apps/mako/mako-1.6-r2.ebuild
+++ b/gui-apps/mako/mako-1.6-r3.ebuild
@@ -13,20 +13,20 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
else
SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="+icons"
+IUSE="elogind +icons systemd"
DEPEND="
dev-libs/wayland
x11-libs/pango
x11-libs/cairo
|| (
- sys-apps/systemd
- sys-auth/elogind
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
sys-libs/basu
)
sys-apps/dbus
@@ -49,5 +49,14 @@ src_configure() {
-Dicons=$(usex icons enabled disabled)
"-Dwerror=false"
)
+
+ if use systemd ; then
+ emesonargs+=( -Dsd-bus-provider=libsystemd )
+ elif use elogind ; then
+ emesonargs+=( -Dsd-bus-provider=libelogind )
+ else
+ emesonargs+=( -Dsd-bus-provider=basu )
+ fi
+
meson_src_configure
}
diff --git a/gui-apps/mako/mako-9999.ebuild b/gui-apps/mako/mako-9999.ebuild
index 920feefafb99..dc520d5f6127 100644
--- a/gui-apps/mako/mako-9999.ebuild
+++ b/gui-apps/mako/mako-9999.ebuild
@@ -18,15 +18,15 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="+icons"
+IUSE="elogind +icons systemd"
DEPEND="
dev-libs/wayland
x11-libs/pango
x11-libs/cairo
|| (
- sys-apps/systemd
- sys-auth/elogind
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
sys-libs/basu
)
sys-apps/dbus
@@ -37,7 +37,7 @@ DEPEND="
"
RDEPEND="
${DEPEND}
- dev-libs/wayland-protocols
+ >=dev-libs/wayland-protocols-1.21
"
BDEPEND="
virtual/pkgconfig
@@ -49,5 +49,14 @@ src_configure() {
-Dicons=$(usex icons enabled disabled)
"-Dwerror=false"
)
+
+ if use systemd ; then
+ emesonargs+=( -Dsd-bus-provider=libsystemd )
+ elif use elogind ; then
+ emesonargs+=( -Dsd-bus-provider=libelogind )
+ else
+ emesonargs+=( -Dsd-bus-provider=basu )
+ fi
+
meson_src_configure
}