summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2022-08-11 18:01:47 +0200
committerMatthew Smith <matthew@gentoo.org>2022-08-13 08:58:12 +0100
commitc960b2b06398d4c2025028a0e1e5ccc54f90395e (patch)
tree3c8500e4d4ac0ce31566c1c4cfa306a7485e8c58 /gui-apps
parentgui-apps/foot-terminfo: add 1.13.0 (diff)
downloadgentoo-c960b2b06398d4c2025028a0e1e5ccc54f90395e.tar.gz
gentoo-c960b2b06398d4c2025028a0e1e5ccc54f90395e.tar.bz2
gentoo-c960b2b06398d4c2025028a0e1e5ccc54f90395e.zip
gui-apps/foot: add 1.13.0
Signed-off-by: Arsen Arsenović <arsen@aarsen.me> Closes: https://github.com/gentoo/gentoo/pull/26824 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/foot/Manifest1
-rw-r--r--gui-apps/foot/foot-1.13.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/gui-apps/foot/Manifest b/gui-apps/foot/Manifest
index 8554377e5bba..273383eb2f65 100644
--- a/gui-apps/foot/Manifest
+++ b/gui-apps/foot/Manifest
@@ -1,2 +1,3 @@
DIST foot-1.11.0.tar.gz 468899 BLAKE2B f3e3909c670598dab151f8be4104921fddd6621e833a8fe43c68d06347e3e866101fe1563282622436638674b7f73770762d47a7b9fd61d42b00bc7634e2ea76 SHA512 edf8130dfb52e06b6d8638115eca19695b24536f3f6b284e0319876edb95c3c86800f9527cc9dae3f66d2d317d26add793634a19f302e52c9f0118b9b91fc9c2
DIST foot-1.12.1.tar.gz 484702 BLAKE2B 5f3ed5923dfe2e3d110da298d4abefb331c15bb0f3db3135a4e8d481b528b3f8287fc5d8516e9d3a34b8084f6364edae93dee496d9192fe610d2c17733277451 SHA512 553f404b074f4372fb8cfb050f0378d1cbe1620ea8afe2e279523df3006eefd0b0ed24addca33de10cfc8109e5aaec66beccbd5f30e032bb9f2bd9b81ac798cb
+DIST foot-1.13.0.tar.gz 495396 BLAKE2B 9acad754d47754d6161fd4024b7f6a8336cd5e6faa1112bdf390c79ecbd52f74b187544667ca8517618f05324af76da66f0320e86e8b0e178a0f63c556992edf SHA512 ac7c8dc967c897f81f8eda8b0c5de17896015698ac266bc9ce898d3fdb41d0dd96762f28f433d8a31f768e0505e4c89151ef10484407f66865ea6322fa1b6705
diff --git a/gui-apps/foot/foot-1.13.0.ebuild b/gui-apps/foot/foot-1.13.0.ebuild
new file mode 100644
index 000000000000..9b2582a0b630
--- /dev/null
+++ b/gui-apps/foot/foot-1.13.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg systemd
+
+DESCRIPTION="Fast, lightweight and minimalistic Wayland terminal emulator"
+HOMEPAGE="https://codeberg.org/dnkl/foot"
+SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64"
+IUSE="+grapheme-clustering"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ media-libs/fcft
+ media-libs/fontconfig
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ grapheme-clustering? (
+ dev-libs/libutf8proc:=
+ media-libs/fcft[harfbuzz]
+ )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/tllist
+ dev-libs/wayland-protocols
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ || (
+ >=sys-libs/ncurses-6.3[-minimal]
+ ~gui-apps/foot-terminfo-${PV}
+ )
+"
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+"
+
+src_prepare() {
+ default
+ # disable the systemd dep, we install the unit file manually
+ sed -i "s/systemd', required: false)$/', required: false)/" "${S}"/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature grapheme-clustering)
+ -Dthemes=true
+ -Dime=true
+ -Dterminfo=disabled
+ )
+ meson_src_configure
+
+ sed 's|@bindir@|/usr/bin|g' "${S}/"/foot-server@.service.in > foot-server@.service
+}
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md LICENSE )
+ meson_src_install
+
+ # foot unconditionally installs CHANGELOG.md, README.md and LICENSE.
+ # we handle this via DOCS and dodoc instead.
+ rm -r "${ED}/usr/share/doc/${PN}" || die
+ systemd_douserunit foot-server@.service "${S}"/foot-server@.socket
+}