summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-12-24 17:01:45 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-12-24 17:11:32 +0000
commitba8667d47371eb6489e1aeb371d04e1acc4b3bf8 (patch)
treeaf76ffd4f7889d36fcf0256cab49db4409776a21 /gui-libs/neatvnc/neatvnc-9999.ebuild
parentdev-libs/aml: Bump to 0.2.2, drop old 0.2.1 (diff)
downloadgentoo-ba8667d47371eb6489e1aeb371d04e1acc4b3bf8.tar.gz
gentoo-ba8667d47371eb6489e1aeb371d04e1acc4b3bf8.tar.bz2
gentoo-ba8667d47371eb6489e1aeb371d04e1acc4b3bf8.zip
gui-libs/neatvnc: Bump to 0.5.4, drop old 0.4.0, EAPI 8
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'gui-libs/neatvnc/neatvnc-9999.ebuild')
-rw-r--r--gui-libs/neatvnc/neatvnc-9999.ebuild32
1 files changed, 22 insertions, 10 deletions
diff --git a/gui-libs/neatvnc/neatvnc-9999.ebuild b/gui-libs/neatvnc/neatvnc-9999.ebuild
index 0e82ff2aa460..c9d35e6f6390 100644
--- a/gui-libs/neatvnc/neatvnc-9999.ebuild
+++ b/gui-libs/neatvnc/neatvnc-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
-DESCRIPTION="liberally licensed VNC server library with a clean interface"
+DESCRIPTION="Liberally licensed VNC server library with a clean interface"
HOMEPAGE="https://github.com/any1/neatvnc/"
if [[ ${PV} == 9999 ]]; then
@@ -13,23 +13,32 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
else
SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~riscv ~x86"
fi
LICENSE="ISC"
SLOT="0"
-IUSE="examples ssl jpeg tracing"
+IUSE="examples gbm h264 jpeg ssl test tracing"
+REQUIRED_USE="h264? ( gbm )"
+RESTRICT="!test? ( test )"
-DEPEND="
- x11-libs/pixman
- x11-libs/libdrm
+RDEPEND="
dev-libs/aml
sys-libs/zlib
- ssl? ( net-libs/gnutls:= )
+ x11-libs/pixman
+ gbm? ( media-libs/mesa )
+ h264? (
+ media-video/ffmpeg:=
+ x11-libs/libdrm
+ )
jpeg? ( media-libs/libjpeg-turbo:= )
+ ssl? ( net-libs/gnutls:= )
tracing? ( dev-util/systemtap )
"
-RDEPEND="${DEPEND}"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libdrm
+"
BDEPEND="
virtual/pkgconfig
"
@@ -37,9 +46,12 @@ BDEPEND="
src_configure() {
local emesonargs=(
$(meson_use examples)
+ $(meson_use test tests)
$(meson_feature jpeg)
$(meson_feature ssl tls)
$(meson_use tracing systemtap)
+ $(meson_feature gbm)
+ $(meson_feature h264)
)
meson_src_configure
}