summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-08-07 15:01:30 -0700
committerYixun Lan <dlan@gentoo.org>2024-08-09 03:17:58 +0000
commit9dc1121e8c6dddce481345877b4315ac23ef4930 (patch)
treef2dd30377a0e2f6ecec5296253c485902a322cbb /gui-wm
parentgui-wm/hyprland: drop 0.40.0-r1 (diff)
downloadgentoo-9dc1121e8c6dddce481345877b4315ac23ef4930.tar.gz
gentoo-9dc1121e8c6dddce481345877b4315ac23ef4930.tar.bz2
gentoo-9dc1121e8c6dddce481345877b4315ac23ef4930.zip
gui-wm/hyprland: add 0.42.0
Closes: https://github.com/gentoo/gentoo/pull/37962 Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hyprland/Manifest1
-rw-r--r--gui-wm/hyprland/hyprland-0.42.0.ebuild94
-rw-r--r--gui-wm/hyprland/metadata.xml4
3 files changed, 99 insertions, 0 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index 501495f11f4c..b4c2dfcc171f 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -1,2 +1,3 @@
DIST hyprland-0.41.1.gh.tar.gz 54813832 BLAKE2B 1dd17e7e1f885da91fca596bf8ce9efc76b3110640a9bc11538fabf975eb55d76180c202527e0b0eac300f027adfed815d2a9a5396a48429097ef2a5ffcc4d9e SHA512 fa63e7c429e33535fa30ca70133f6ac8617f2386bdca1e8063628a2895677c9b80965548ee21f897aea2fe6bdcc10d74d8c46989a7563b36504f4a4f43c3eaad
DIST hyprland-0.41.2.gh.tar.gz 54821598 BLAKE2B 026559e9319690e6b48863ffdc2e059c969ab45e7bfe75578b7e41f1d10b36e720ae0655f7003107a4ff4e94c1e95aba3e8a1af8ed01bae369c571e24d966aec SHA512 5a138d9ad6de2d45d8d0a5cde8c39ba3cd4c6bac61caf5b9f8520d0adcafe6ac1dfec4c529b8a6608133ffe9409935c1414a86d98d743be6766bdbc72641179d
+DIST hyprland-0.42.0.gh.tar.gz 54225438 BLAKE2B a947289c5568408d71383034a290f114b974f442ed1f56ac3ec30e49519ee886ac83e1f2611577a7240a555480a59bc01defb79b2aca2122ef0d81ea007f5486 SHA512 839916957abc867ad9a3a32b6f74830055060b99c4c1de314f71a85f8d55ef051c5adb7c79dd7a7e10f81d1130aa032458bb65ce2454198a79faa719021f66af
diff --git a/gui-wm/hyprland/hyprland-0.42.0.ebuild b/gui-wm/hyprland/hyprland-0.42.0.ebuild
new file mode 100644
index 000000000000..0201229de28e
--- /dev/null
+++ b/gui-wm/hyprland/hyprland-0.42.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
+HOMEPAGE="https://github.com/hyprwm/Hyprland"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-source"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="X legacy-renderer systemd"
+
+# hyprpm (hyprland plugin manager) requires the dependencies at runtime
+# so that it can clone, compile and install plugins.
+HYPRPM_RDEPEND="
+ app-alternatives/ninja
+ dev-build/cmake
+ dev-build/meson
+ dev-libs/libliftoff
+ dev-vcs/git
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${HYPRPM_RDEPEND}
+ dev-cpp/tomlplusplus
+ dev-libs/glib:2
+ dev-libs/libinput
+ >=dev-libs/wayland-1.20.0
+ gui-libs/aquamarine
+ >=gui-libs/hyprcursor-0.1.9
+ media-libs/libglvnd
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ X? (
+ x11-libs/libxcb:0=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ ${WLROOTS_DEPEND}
+ >=dev-libs/hyprland-protocols-0.3
+ >=dev-libs/hyprlang-0.3.2
+ >=dev-libs/wayland-protocols-1.36
+ >=gui-libs/hyprutils-0.2.1
+"
+BDEPEND="
+ ${WLROOTS_BDEPEND}
+ || ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
+ app-misc/jq
+ dev-build/cmake
+ >=dev-util/hyprwayland-scanner-0.3.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
+ eerror "Hyprland requires >=sys-devel/gcc-13 to build"
+ eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+ die "GCC version is too old to compile Hyprland!"
+ elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
+ eerror "Hyprland requires >=sys-devel/clang-16 to build"
+ eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ die "Clang version is too old to compile Hyprland!"
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature legacy-renderer legacy_renderer)
+ $(meson_feature systemd)
+ $(meson_feature X xwayland)
+ -Dwlroots:backends=drm,libinput$(usev X ',x11')
+ -Dwlroots:xcb-errors=disabled
+ )
+
+ meson_src_configure
+}
diff --git a/gui-wm/hyprland/metadata.xml b/gui-wm/hyprland/metadata.xml
index e894da71d007..5bea9a35e357 100644
--- a/gui-wm/hyprland/metadata.xml
+++ b/gui-wm/hyprland/metadata.xml
@@ -5,6 +5,10 @@
<email>julien@jroy.ca</email>
<name>Julien Roy</name>
</maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>johnmh@johnmh.me</email>
+ <name>John M. Harris, Jr.</name>
+ </maintainer>
<maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>