summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-09-12 17:59:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-12 21:27:33 +0200
commit74385e112f3f37e2c7cff2cfe8917bcc3fb8750d (patch)
tree4885abee061df0467d480f0d99f1b0271ceb41b2 /kde-apps/calendarjanitor/calendarjanitor-24.08.1.ebuild
parentkde-apps/akregator: 24.08.1 version bump (diff)
downloadgentoo-74385e112f3f37e2c7cff2cfe8917bcc3fb8750d.tar.gz
gentoo-74385e112f3f37e2c7cff2cfe8917bcc3fb8750d.tar.bz2
gentoo-74385e112f3f37e2c7cff2cfe8917bcc3fb8750d.zip
kde-apps/calendarjanitor: 24.08.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/calendarjanitor/calendarjanitor-24.08.1.ebuild')
-rw-r--r--kde-apps/calendarjanitor/calendarjanitor-24.08.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-apps/calendarjanitor/calendarjanitor-24.08.1.ebuild b/kde-apps/calendarjanitor/calendarjanitor-24.08.1.ebuild
new file mode 100644
index 000000000000..4c96cf694ffb
--- /dev/null
+++ b/kde-apps/calendarjanitor/calendarjanitor-24.08.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoff"
+ECM_TEST="false"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Tool to scan calendar data for buggy instances"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-apps/akonadi-${PVCUT}:6
+ >=kde-apps/akonadi-calendar-${PVCUT}:6
+ >=kde-apps/calendarsupport-${PVCUT}:6
+ >=kde-frameworks/kcalendarcore-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ >=kde-apps/akonadi-calendar-tools-common-${PV}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-24.05.2-loggingcategory.patch" )
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+ cmake_comment_add_subdirectory konsolekalendar
+}