summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 15:29:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 15:30:09 +0200
commitd9397ab8d48feb4b1360be614da35fa2faae44d9 (patch)
treecc33135aeeb6bb0faab58e8efc34329c14dff2b0 /kde-apps/dolphin
parentdev-libs/libnl: Add USE='debug threads'. (diff)
downloadgentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.tar.gz
gentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.tar.bz2
gentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.zip
kde-apps: Add KDE Applications 18.04.1
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-18.04.1.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index de50bba6ae5d..5e9b60046d8b 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-17.12.3.tar.xz 4841752 BLAKE2B 1f58cb0f1663e131a1b8dc58fc47d40a8a68bcb998fd3c6191f99176263523d40c1d9057b569c10c14e2a6b0be91b2eaaf07a54acdd386984d0da167cb84fabd SHA512 44cf8baaeead69dd5529ce7da96d78f507029fa47ac9ac50de9d77cb15335dd0b0e0c916f2cdd0d5cadc465e461115dbfd02c51af38d03da985d66bd22456136
DIST dolphin-18.04.0.tar.xz 4843460 BLAKE2B 408e0c3797885a80d128247f178e4b966fdd280c5538fcccd40e4cee7bde6d7821616df098e28b79fcd3136a6b14b654ee053ff6bee0c6424613e9560bf55f01 SHA512 9c941c37d8c1b132c092a3c71f75b821427b170ded6be8a0d1ca19a5807c9c2689cd695ee8e953443e2769358e3a28704c1880671a1fa0daaae9c1149cc12642
+DIST dolphin-18.04.1.tar.xz 4849868 BLAKE2B 3335ced611590b51200135207b5bc5e2266504c7d556e8a903b6f3f63131547369d1fcccce8f13f93f4f15c84e695827ef4deb6088e5ec6219c15f85c140313f SHA512 13c9f45282168a4ae68b9d0977b1734918c662028043167ab36bc67b7b7f1756930a613e7bbd25bafc6db7e1591524f2ec3002247838ddbf0dc49037d4c7a0fd
diff --git a/kde-apps/dolphin/dolphin-18.04.1.ebuild b/kde-apps/dolphin/dolphin-18.04.1.ebuild
new file mode 100644
index 000000000000..256cdd947622
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-18.04.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://www.kde.org/applications/system/dolphin https://userbase.kde.org/Dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ $(add_kdeapps_dep ffmpegthumbs)
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/ark:${SLOT}" ; then
+ elog "For compress/extract and other actions, please install kde-apps/ark:${SLOT}"
+ fi
+
+ if ! has_version "kde-apps/kleopatra:${SLOT}" ; then
+ elog "For crypto actions, please install kde-apps/kleopatra:${SLOT}"
+ fi
+}