summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-28 22:24:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-28 23:32:25 +0100
commit8a8382264b06c181b312b99ba422fffa4a93a797 (patch)
tree62fa7a28b0d221ac3a116c74dde9af822cab9dc4 /kde-apps/kmail
parentapp-misc/geoclue: update metadata (diff)
downloadgentoo-8a8382264b06c181b312b99ba422fffa4a93a797.tar.gz
gentoo-8a8382264b06c181b312b99ba422fffa4a93a797.tar.bz2
gentoo-8a8382264b06c181b312b99ba422fffa4a93a797.zip
kde-apps/kmail: Backport various fixes to 22.08.3 and 22.12.1
In 22.08.3-r2 and 22.12.3-r2: - Crash on attempting to replay a message with a user template KDE-bug: https://bugs.kde.org/show_bug.cgi?id=463935 In 22.08.3-r2: - Opening the detailed progress window does nothing KDE-bug: https://bugs.kde.org/show_bug.cgi?id=460289 - Kontact Crashes Upon Start KDE-bug: https://bugs.kde.org/show_bug.cgi?id=460747 - ShowUserAgent=true does not show x-mailer KDE-bug: https://bugs.kde.org/show_bug.cgi?id=448348 - Random text in kmail's message list configuration settings KDE-bug: https://bugs.kde.org/show_bug.cgi?id=459399 Bug: https://bugs.gentoo.org/891509 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kmail')
-rw-r--r--kde-apps/kmail/files/kmail-22.08.3-fix-crash-on-replay-msg-w-user-template.patch38
-rw-r--r--kde-apps/kmail/files/kmail-22.08.3-fix-crash-on-startup.patch47
-rw-r--r--kde-apps/kmail/files/kmail-22.08.3-fix-open-detailed-progress-bar.patch52
-rw-r--r--kde-apps/kmail/files/kmail-22.08.3-fix-random-text-in-config-settings.patch29
-rw-r--r--kde-apps/kmail/files/kmail-22.08.3-remove-removed-ShowUserAgent.patch41
-rw-r--r--kde-apps/kmail/kmail-22.08.3-r2.ebuild123
-rw-r--r--kde-apps/kmail/kmail-22.12.1-r2.ebuild119
7 files changed, 449 insertions, 0 deletions
diff --git a/kde-apps/kmail/files/kmail-22.08.3-fix-crash-on-replay-msg-w-user-template.patch b/kde-apps/kmail/files/kmail-22.08.3-fix-crash-on-replay-msg-w-user-template.patch
new file mode 100644
index 000000000000..5692a4916129
--- /dev/null
+++ b/kde-apps/kmail/files/kmail-22.08.3-fix-crash-on-replay-msg-w-user-template.patch
@@ -0,0 +1,38 @@
+From 94e28559c96b71721b02393a23cbfeefa93a607b Mon Sep 17 00:00:00 2001
+From: Laurent Montel <montel@kde.org>
+Date: Sat, 7 Jan 2023 00:31:18 +0100
+Subject: [PATCH] Fix bug 463935: Crash on attempting to replay a message with
+ an user template
+
+BUG: 463935
+FIXED-IN: 5.22.2
+---
+ src/kmmainwidget.cpp | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/src/kmmainwidget.cpp b/src/kmmainwidget.cpp
+index b00db6f53..3ab6a18af 100644
+--- a/src/kmmainwidget.cpp
++++ b/src/kmmainwidget.cpp
+@@ -2096,8 +2096,7 @@ void KMMainWidget::slotCustomReplyAllToMsg(const QString &tmpl)
+ qCDebug(KMAIL_LOG) << "Reply to All with template:" << tmpl;
+
+ auto command = new KMReplyCommand(this, msg, MessageComposer::ReplyAll, text, false, tmpl);
+- command->setReplyAsHtml(messageView()->htmlMail());
+-
++ command->setReplyAsHtml(messageView() ? messageView()->htmlMail() : false);
+ command->start();
+ }
+
+@@ -4745,7 +4744,7 @@ void KMMainWidget::slotRedirectCurrentMessage()
+ void KMMainWidget::replyMessageTo(const Akonadi::Item &item, bool replyToAll)
+ {
+ auto command = new KMReplyCommand(this, item, replyToAll ? MessageComposer::ReplyAll : MessageComposer::ReplyAuthor);
+- command->setReplyAsHtml(messageView()->htmlMail());
++ command->setReplyAsHtml(messageView() ? messageView()->htmlMail() : false);
+ command->start();
+ }
+
+--
+GitLab
+
diff --git a/kde-apps/kmail/files/kmail-22.08.3-fix-crash-on-startup.patch b/kde-apps/kmail/files/kmail-22.08.3-fix-crash-on-startup.patch
new file mode 100644
index 000000000000..a798f1afe567
--- /dev/null
+++ b/kde-apps/kmail/files/kmail-22.08.3-fix-crash-on-startup.patch
@@ -0,0 +1,47 @@
+From 9d37b837eca35bd7976709a9d25d3700c70e321e Mon Sep 17 00:00:00 2001
+From: Laurent Montel <montel@kde.org>
+Date: Sat, 31 Dec 2022 10:55:34 +0100
+Subject: [PATCH] Fix bug 460747: Kontact Crashes Upon Start
+
+BUG: 460747
+FIXED-IN: 5.22.1
+---
+ src/kmmainwidget.cpp | 15 ++++++++-------
+ 1 file changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/src/kmmainwidget.cpp b/src/kmmainwidget.cpp
+index 8d332b36b..8c7013f8b 100644
+--- a/src/kmmainwidget.cpp
++++ b/src/kmmainwidget.cpp
+@@ -3403,6 +3403,14 @@ void KMMainWidget::setupActions()
+ QAction *act = actionCollection()->addAction(KStandardAction::Undo, QStringLiteral("kmail_undo"));
+ connect(act, &QAction::triggered, this, &KMMainWidget::slotUndo);
+
++ mAccountSettings = new QAction(QIcon::fromTheme(QStringLiteral("configure")), i18n("Account &Settings"), this);
++ actionCollection()->addAction(QStringLiteral("resource_settings"), mAccountSettings);
++ connect(mAccountSettings, &QAction::triggered, this, &KMMainWidget::slotAccountSettings);
++
++ mRestartAccountSettings = new QAction(QIcon::fromTheme(QStringLiteral("view-refresh")), i18n("Restart Account"), this);
++ actionCollection()->addAction(QStringLiteral("resource_restart"), mRestartAccountSettings);
++ connect(mRestartAccountSettings, &QAction::triggered, this, &KMMainWidget::slotRestartAccount);
++
+ menutimer = new QTimer(this);
+ menutimer->setObjectName(QStringLiteral("menutimer"));
+ menutimer->setSingleShot(true);
+@@ -3535,13 +3543,6 @@ void KMMainWidget::setupActions()
+ actionCollection()->addAction(QStringLiteral("remove_duplicate_recursive"), mRemoveDuplicateRecursiveAction);
+ connect(mRemoveDuplicateRecursiveAction, &KToggleAction::triggered, this, &KMMainWidget::slotRemoveDuplicateRecursive);
+
+- mAccountSettings = new QAction(QIcon::fromTheme(QStringLiteral("configure")), i18n("Account &Settings"), this);
+- actionCollection()->addAction(QStringLiteral("resource_settings"), mAccountSettings);
+- connect(mAccountSettings, &QAction::triggered, this, &KMMainWidget::slotAccountSettings);
+-
+- mRestartAccountSettings = new QAction(QIcon::fromTheme(QStringLiteral("view-refresh")), i18n("Restart Account"), this);
+- actionCollection()->addAction(QStringLiteral("resource_restart"), mRestartAccountSettings);
+- connect(mRestartAccountSettings, &QAction::triggered, this, &KMMainWidget::slotRestartAccount);
+ {
+ QList<QAction *> listActions;
+ auto act = new QAction(i18n("Previous Selected Folder"), this); // TODO fix me i18n
+--
+GitLab
+
diff --git a/kde-apps/kmail/files/kmail-22.08.3-fix-open-detailed-progress-bar.patch b/kde-apps/kmail/files/kmail-22.08.3-fix-open-detailed-progress-bar.patch
new file mode 100644
index 000000000000..1ff35b388dc7
--- /dev/null
+++ b/kde-apps/kmail/files/kmail-22.08.3-fix-open-detailed-progress-bar.patch
@@ -0,0 +1,52 @@
+From 437295a534eca2907e749f18d8d895da50d343b9 Mon Sep 17 00:00:00 2001
+From: Laurent Montel <montel@kde.org>
+Date: Sat, 10 Dec 2022 19:55:33 +0100
+Subject: [PATCH] Fix bug 460289: Opening the detailed progress window does
+ nothing
+
+BUG: 460289
+FIXED-IN: 5.22.1
+---
+ src/kmmainwin.cpp | 5 ++++-
+ src/kmmainwin.h | 2 +-
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/kmmainwin.cpp b/src/kmmainwin.cpp
+index 5900bf309..9952667fe 100644
+--- a/src/kmmainwin.cpp
++++ b/src/kmmainwin.cpp
+@@ -36,7 +36,6 @@ using namespace std::chrono_literals;
+
+ KMMainWin::KMMainWin(QWidget *)
+ : KXmlGuiWindow(nullptr)
+- , mProgressBar(new KPIM::ProgressStatusBarWidget(statusBar(), this))
+ , mMessageLabel(new QLabel(i18n("Starting...")))
+
+ {
+@@ -51,6 +50,10 @@ KMMainWin::KMMainWin(QWidget *)
+ resize(700, 500); // The default size
+
+ mKMMainWidget = new KMMainWidget(this, this, actionCollection());
++
++ // Don't initialize in constructor. We need this statusbar created
++ // Bug 460289
++ mProgressBar = new KPIM::ProgressStatusBarWidget(statusBar(), this);
+ connect(mKMMainWidget, &KMMainWidget::recreateGui, this, &KMMainWin::slotUpdateGui);
+ setCentralWidget(mKMMainWidget);
+ setupStatusBar();
+diff --git a/src/kmmainwin.h b/src/kmmainwin.h
+index 314f14d47..377f6818b 100644
+--- a/src/kmmainwin.h
++++ b/src/kmmainwin.h
+@@ -57,7 +57,7 @@ private:
+ void updateHamburgerMenu();
+ void slotShortcutSaved();
+ void slotFullScreen(bool t);
+- KPIM::ProgressStatusBarWidget *const mProgressBar;
++ KPIM::ProgressStatusBarWidget *mProgressBar = nullptr;
+ KMMainWidget *mKMMainWidget = nullptr;
+ KToggleAction *mShowMenuBarAction = nullptr;
+ QLabel *const mMessageLabel;
+--
+GitLab
+
diff --git a/kde-apps/kmail/files/kmail-22.08.3-fix-random-text-in-config-settings.patch b/kde-apps/kmail/files/kmail-22.08.3-fix-random-text-in-config-settings.patch
new file mode 100644
index 000000000000..282fb6109acc
--- /dev/null
+++ b/kde-apps/kmail/files/kmail-22.08.3-fix-random-text-in-config-settings.patch
@@ -0,0 +1,29 @@
+From 6618f8f80ccadff908d11db7506b3af8d15ad032 Mon Sep 17 00:00:00 2001
+From: Laurent Montel <montel@kde.org>
+Date: Fri, 16 Dec 2022 06:59:17 +0100
+Subject: [PATCH] BUG: 459399 Fix Random text in kmail's message list
+ configuration settings
+
+Apply patch from Yaroslav Sidlovsky (thanks)
+BUG: 459399
+FIXED-IN: 5.22.1
+---
+ src/configuredialog/configureappearancepage.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/configuredialog/configureappearancepage.cpp b/src/configuredialog/configureappearancepage.cpp
+index 085179f05..0909db227 100644
+--- a/src/configuredialog/configureappearancepage.cpp
++++ b/src/configuredialog/configureappearancepage.cpp
+@@ -622,7 +622,7 @@ AppearancePageHeadersTab::AppearancePageHeadersTab(QWidget *parent)
+ .subs(DateFormatter::formatCurrentDate(dateDisplayConfig[i].dateDisplay))
+ .toString(); // i18n(label, DateFormatter::formatCurrentDate(dateDisplayConfig[i].dateDisplay));
+ } else {
+- buttonLabel = i18n(label);
++ buttonLabel = KLocalizedString(dateDisplayConfig[i].displayName).toString();
+ }
+ if (dateDisplayConfig[i].dateDisplay == DateFormatter::Custom) {
+ auto hbox = new QWidget(this);
+--
+GitLab
+
diff --git a/kde-apps/kmail/files/kmail-22.08.3-remove-removed-ShowUserAgent.patch b/kde-apps/kmail/files/kmail-22.08.3-remove-removed-ShowUserAgent.patch
new file mode 100644
index 000000000000..a6484b11ae50
--- /dev/null
+++ b/kde-apps/kmail/files/kmail-22.08.3-remove-removed-ShowUserAgent.patch
@@ -0,0 +1,41 @@
+From fc0b487d3f3ac9c9ca0650aa635795b5478de85b Mon Sep 17 00:00:00 2001
+From: Laurent Montel <montel@kde.org>
+Date: Fri, 16 Dec 2022 07:28:28 +0100
+Subject: [PATCH] Remove info about removed feature (ShowUserAgent)
+
+CCBUG: 448348
+---
+ doc/kmail2/configure.docbook | 17 -----------------
+ 1 file changed, 17 deletions(-)
+
+diff --git a/doc/kmail2/configure.docbook b/doc/kmail2/configure.docbook
+index 4916acd8b..bb2648370 100644
+--- a/doc/kmail2/configure.docbook
++++ b/doc/kmail2/configure.docbook
+@@ -4167,23 +4167,6 @@ behavior, add to the [OutOfOffice] section:</para>
+ </itemizedlist>
+ </listitem>
+ </varlistentry>
+-<varlistentry>
+-<term><guilabel>ShowUserAgent</guilabel></term>
+-<listitem>
+-<para>
+-Starting in version 1.9, &kmail; can show the User-Agent or X-Mailer value
+-from the message header when using Fancy Headers (see <menuchoice><guimenu>View</guimenu>
+-<guisubmenu>Headers</guisubmenu></menuchoice> menu).
+-To enable this feature, add to the <quote>[Reader]</quote> section:</para>
+-<itemizedlist>
+-<listitem><para>Configuration file:</para>
+-<programlisting>ShowUserAgent=true</programlisting></listitem>
+-<listitem><para><command>kwriteconfig</command></para>
+-<para><prompt>&percnt;</prompt> <userinput><command>kwriteconfig</command> <option>--file <replaceable>/path/to/kmail2rc</replaceable> --group Reader --key ShowUserAgent true</option></userinput>
+-</para></listitem>
+-</itemizedlist>
+-</listitem>
+-</varlistentry>
+ </variablelist>
+ </sect1>
+
+--
+GitLab
+
diff --git a/kde-apps/kmail/kmail-22.08.3-r2.ebuild b/kde-apps/kmail/kmail-22.08.3-r2.ebuild
new file mode 100644
index 000000000000..1bbe4c685f7c
--- /dev/null
+++ b/kde-apps/kmail/kmail-22.08.3-r2.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.96.0
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm gear.kde.org optfeature
+
+DESCRIPTION="Email client, supporting POP3 and IMAP mailboxes"
+HOMEPAGE="https://apps.kde.org/kmail2/
+https://kontact.kde.org/components/kmail/"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="amd64 arm64 ~ppc64 x86"
+IUSE="pch speech telemetry"
+
+RESTRICT="test" # bug 616878
+
+# kde-frameworks/kwindowsystem[X]: Unconditional use of KX11Extras
+COMMON_DEPEND="
+ >=app-crypt/gpgme-1.16.0:=[cxx,qt5]
+ >=dev-qt/qtcore-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwebengine-${QTMIN}:5[widgets]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-mime-${PVCUT}:5
+ >=kde-apps/akonadi-search-${PVCUT}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kontactinterface-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5[speech=]
+ >=kde-apps/libgravatar-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=kde-apps/libksieve-${PVCUT}:5
+ >=kde-apps/libktnef-${PVCUT}:5
+ >=kde-apps/mailcommon-${PVCUT}:5
+ >=kde-apps/messagelib-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5[X]
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/sonnet-${KFMIN}:5
+ telemetry? ( >=dev-libs/kuserfeedback-1.2.0:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-apps/kldap-${PVCUT}:5
+ test? ( >=kde-apps/akonadi-${PVCUT}:5[sqlite] )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=kde-apps/kdepim-runtime-${PVCUT}:5
+ >=kde-apps/kmail-account-wizard-${PVCUT}:5
+"
+BDEPEND="
+ dev-libs/libxslt
+ test? ( >=kde-apps/akonadi-${PVCUT}:5[tools] )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-open-detailed-progress-bar.patch" # bug 891509
+ "${FILESDIR}/${P}-fix-random-text-in-config-settings.patch"
+ "${FILESDIR}/${P}-remove-removed-ShowUserAgent.patch"
+ "${FILESDIR}/${P}-fix-crash-on-startup.patch"
+ "${FILESDIR}/${P}-fix-crash-on-replay-msg-w-user-template.patch"
+)
+
+src_prepare() {
+ ecm_src_prepare
+ use handbook || cmake_run_in ktnef cmake_comment_add_subdirectory doc
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_PRECOMPILED_HEADERS=$(usex pch)
+ $(cmake_use_find_package telemetry KUserFeedback)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "virus detection" app-antivirus/clamav
+ optfeature "spam filtering" mail-filter/bogofilter mail-filter/spamassassin
+ optfeature "fancy e-mail headers and useful plugins" kde-apps/kdepim-addons:${SLOT}
+ optfeature "crypto config and certificate details GUI" kde-apps/kleopatra:${SLOT}
+ optfeature "import PIM data from other applications" kde-apps/akonadi-import-wizard:${SLOT}
+ fi
+ ecm_pkg_postinst
+}
diff --git a/kde-apps/kmail/kmail-22.12.1-r2.ebuild b/kde-apps/kmail/kmail-22.12.1-r2.ebuild
new file mode 100644
index 000000000000..4130f4de525d
--- /dev/null
+++ b/kde-apps/kmail/kmail-22.12.1-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.101.0
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm gear.kde.org optfeature
+
+DESCRIPTION="Email client, supporting POP3 and IMAP mailboxes"
+HOMEPAGE="https://apps.kde.org/kmail2/
+https://kontact.kde.org/components/kmail/"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="pch speech telemetry"
+
+RESTRICT="test" # bug 616878
+
+# kde-frameworks/kwindowsystem[X]: Unconditional use of KX11Extras
+COMMON_DEPEND="
+ >=app-crypt/gpgme-1.16.0:=[cxx,qt5]
+ >=dev-qt/qtcore-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwebengine-${QTMIN}:5[widgets]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-mime-${PVCUT}:5
+ >=kde-apps/akonadi-search-${PVCUT}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kontactinterface-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5[speech=]
+ >=kde-apps/libgravatar-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=kde-apps/libksieve-${PVCUT}:5
+ >=kde-apps/libktnef-${PVCUT}:5
+ >=kde-apps/mailcommon-${PVCUT}:5
+ >=kde-apps/messagelib-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5[X]
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/sonnet-${KFMIN}:5
+ telemetry? ( >=dev-libs/kuserfeedback-1.2.0:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-apps/kldap-${PVCUT}:5
+ test? ( >=kde-apps/akonadi-${PVCUT}:5[sqlite] )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=kde-apps/kdepim-runtime-${PVCUT}:5
+ >=kde-apps/kmail-account-wizard-${PVCUT}:5
+"
+BDEPEND="
+ dev-libs/libxslt
+ test? ( >=kde-apps/akonadi-${PVCUT}:5[tools] )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-22.08.3-fix-crash-on-replay-msg-w-user-template.patch"
+)
+
+src_prepare() {
+ ecm_src_prepare
+ use handbook || cmake_run_in ktnef cmake_comment_add_subdirectory doc
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_PRECOMPILED_HEADERS=$(usex pch)
+ $(cmake_use_find_package telemetry KUserFeedback)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "virus detection" app-antivirus/clamav
+ optfeature "spam filtering" mail-filter/bogofilter mail-filter/spamassassin
+ optfeature "fancy e-mail headers and useful plugins" kde-apps/kdepim-addons:${SLOT}
+ optfeature "crypto config and certificate details GUI" kde-apps/kleopatra:${SLOT}
+ optfeature "import PIM data from other applications" kde-apps/akonadi-import-wizard:${SLOT}
+ fi
+ ecm_pkg_postinst
+}