summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 09:30:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 16:50:00 +0100
commitf1b6a4697cb6bd8b01b005cca0996982fd736a2d (patch)
tree9b2799b0df1355e0ee40b8c909752698a0803837 /kde-apps/ksystemlog
parentapp-emulation/libvirt: init submodules for live ebuild (diff)
downloadgentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.gz
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.bz2
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.zip
kde-apps: Add KDE Applications 18.12.1
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ksystemlog')
-rw-r--r--kde-apps/ksystemlog/Manifest1
-rw-r--r--kde-apps/ksystemlog/ksystemlog-18.12.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-apps/ksystemlog/Manifest b/kde-apps/ksystemlog/Manifest
index 24726ae0752d..4b07fa700aaa 100644
--- a/kde-apps/ksystemlog/Manifest
+++ b/kde-apps/ksystemlog/Manifest
@@ -1,2 +1,3 @@
DIST ksystemlog-18.08.3.tar.xz 1966776 BLAKE2B f6715026b009296856c9120b0236b4efff681d1cd02d7694db8dde3d8df7a521c0640540ee3b1cfd69d1cf8bf8a6976773a217dcfcacbde5f4aaeb2689786fe9 SHA512 0cdf798c3d6c51851fd3cc2eda04e445a413459ee29d7b98d799a749d21a6a80447bce37651ac22e4b652fc10452dc2fb6408108cce2a968e7fc7f2379b0c915
DIST ksystemlog-18.12.0.tar.xz 1964412 BLAKE2B 9dceb8df613f7ed2d316bcdf0284f952947fa384660296e516d1c8883c04b82383d7d5dd93cd49c7dedf16e119fbfc8c9ba2c644c200f1189fc737607ba34f7a SHA512 3d22774144f2d2e52926a10b5ff93e1ae9e356fb60457aa9cc6c81535307214d0ab7d4339d221450f42166dfd8153ea608cb03e808d0a66d01a92fdcd63c93c2
+DIST ksystemlog-18.12.1.tar.xz 1924228 BLAKE2B c7742e1f03a0d8eb034ee2ed5b08132361d45335219a4f99eb9e6be857b68aa2794d3d213f0f6f05b3d0bcfbb1d78358aa1b0b1b46665c3086cc90d2f9244bd4 SHA512 93e5beaab4f064ad09edd24f15a6eb9f7b4a7823b7edf5af8b4b788d6677c268e2582f421ef28baad9dead1474ce6519745058da281441cc60de94725a62a03c
diff --git a/kde-apps/ksystemlog/ksystemlog-18.12.1.ebuild b/kde-apps/ksystemlog/ksystemlog-18.12.1.ebuild
new file mode 100644
index 000000000000..d782c0bee352
--- /dev/null
+++ b/kde-apps/ksystemlog/ksystemlog-18.12.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="System log viewer by KDE"
+HOMEPAGE="https://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+# bug 378101
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package systemd Journald)
+ )
+ kde5_src_configure
+}