summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-12-16 19:38:26 +0100
committerJohannes Huber <johu@gentoo.org>2016-12-16 19:38:38 +0100
commit31645664f42a588800ba68febd89a9c9e6afc76f (patch)
treeccc391e5d2b2b2255adcafe060246a5ddf9a3396 /kde-apps/libkface/libkface-16.12.0.ebuild
parentprofiles: Update masks for KDE Applications 16.12 (diff)
downloadgentoo-31645664f42a588800ba68febd89a9c9e6afc76f.tar.gz
gentoo-31645664f42a588800ba68febd89a9c9e6afc76f.tar.bz2
gentoo-31645664f42a588800ba68febd89a9c9e6afc76f.zip
kde-apps: Version bump KDE Applications 16.12.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/libkface/libkface-16.12.0.ebuild')
-rw-r--r--kde-apps/libkface/libkface-16.12.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-apps/libkface/libkface-16.12.0.ebuild b/kde-apps/libkface/libkface-16.12.0.ebuild
new file mode 100644
index 000000000000..7925a104c08b
--- /dev/null
+++ b/kde-apps/libkface/libkface-16.12.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_BLOCK_SLOT4="false"
+inherit kde5
+
+DESCRIPTION="Qt/C++ wrapper around LibFace to perform face recognition and detection"
+HOMEPAGE="https://projects.kde.org/projects/kde/kdegraphics/libs/libkface"
+
+LICENSE="BSD GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/opencv:=
+ || ( <media-libs/opencv-3.0.0 >=media-libs/opencv-3.1.0-r6[contrib] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-16.11.80-opencv3.2-gentoo-3.1.patch" ) # not upstreamable like that
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_OPENCV3=$(has_version ">=media-libs/opencv-3" && echo yes || echo no)
+ )
+
+ kde5_src_configure
+}