summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-09-15 21:33:27 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-09-15 21:38:26 +1000
commit5bc2531e9317b8679cc9e1ae68ee5883518bb613 (patch)
tree29fde51ed18962fcd1f1c5cf98f58ba728bc67f7 /kde-apps/pimcommon
parentprofiles: mask >=kde-apps/minuet-16.08.0 as it requires masked Qt 5.7 (diff)
downloadgentoo-5bc2531e9317b8679cc9e1ae68ee5883518bb613.tar.gz
gentoo-5bc2531e9317b8679cc9e1ae68ee5883518bb613.tar.bz2
gentoo-5bc2531e9317b8679cc9e1ae68ee5883518bb613.zip
kde-apps: version bump 16.08.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-apps/pimcommon')
-rw-r--r--kde-apps/pimcommon/Manifest1
-rw-r--r--kde-apps/pimcommon/metadata.xml11
-rw-r--r--kde-apps/pimcommon/pimcommon-16.08.1.ebuild55
3 files changed, 67 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/Manifest b/kde-apps/pimcommon/Manifest
new file mode 100644
index 000000000000..4f558d422ac4
--- /dev/null
+++ b/kde-apps/pimcommon/Manifest
@@ -0,0 +1 @@
+DIST pimcommon-16.08.1.tar.xz 154616 SHA256 708bb879f219ac0824f3bc4e473e9ef65a5f809d4f9444a895a0bb57c18925d8 SHA512 4c8d0bde66c601b9f4eaf4017c68a9ad32eb48f85414d2085a69b9d180a16838df407f4430fc4323b53324ef6bbf8a8b76dd5c5d51fcfa546fca3c049b037131 WHIRLPOOL 4641cccba02fe8dcd48e14139be7d2f6eb4b0db5fc093f0a7e1a259f6ca0332994be8ff6b168547cc4d9ccb0cc4da3e63616c986cc5761b29380a8f1edd19e68
diff --git a/kde-apps/pimcommon/metadata.xml b/kde-apps/pimcommon/metadata.xml
new file mode 100644
index 000000000000..a50ada50ef0e
--- /dev/null
+++ b/kde-apps/pimcommon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <use>
+ <flag name="designer">Build plugins for <pkg>dev-qt/designer</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/kde-apps/pimcommon/pimcommon-16.08.1.ebuild b/kde-apps/pimcommon/pimcommon-16.08.1.ebuild
new file mode 100644
index 000000000000..bd7e605bb803
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-16.08.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Common PIM libraries"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep kpimtextedit)
+ $(add_kdeapps_dep libkdepim)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/grantlee:5
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+"