summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-11-17 06:03:26 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-11-17 06:03:53 +1100
commitd185c5cb325c0f23795538e1c25ae639c8e69040 (patch)
treefce2ac2182bbdc2fd982850cd177e801efe9bc14 /kde-frameworks/frameworkintegration/frameworkintegration-5.28.0.ebuild
parentkde-apps/kdeadmin-meta: Drop obsolete comment (diff)
downloadgentoo-d185c5cb325c0f23795538e1c25ae639c8e69040.tar.gz
gentoo-d185c5cb325c0f23795538e1c25ae639c8e69040.tar.bz2
gentoo-d185c5cb325c0f23795538e1c25ae639c8e69040.zip
kde-frameworks: version bump 5.28.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-frameworks/frameworkintegration/frameworkintegration-5.28.0.ebuild')
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.28.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.28.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.28.0.ebuild
new file mode 100644
index 000000000000..14bdd104a79e
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.28.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}