summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 00:36:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-14 08:51:25 +0200
commit9efd24de6c1fdb4a027b91db473262aba16731e0 (patch)
tree2b546c79713a9915fb32d1fd0542ba5c5354ed81 /kde-frameworks/kauth
parentprofiles: mask ruby 2.4 for removal (diff)
downloadgentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.tar.gz
gentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.tar.bz2
gentoo-9efd24de6c1fdb4a027b91db473262aba16731e0.zip
kde-frameworks: Add KDE Frameworks 5.71.0
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.71.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index 1896ed773740..0346d8845b4e 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1 +1,2 @@
DIST kauth-5.70.0.tar.xz 86396 BLAKE2B 1547fa301a2aa3a2db2257e635df24a1ecaaa77f09bba41180b1fbb02d766c124ab5aa681c1e82abe73e0713a276b6857b9da05493ef415b530b8680d37420f1 SHA512 736c372732bff566f0f7beaa953e8b8ddb930b08cb4269e38174523fbfe6b77041dc3141980f109ec15d176a5d367dd05dd58e1fcca234f7eee828a456fde906
+DIST kauth-5.71.0.tar.xz 87368 BLAKE2B 8c0d99430fbf28c21b76d99a009050d6b91fafad5c8761bcc265b9ac044577cdc1f8a692abfdcf6f5c6ea667f6185be3d4efce99edf145ccc65af09c06714c57 SHA512 1b34583c37a10250cbbfb8a8a4da7f72c1b358e8946909985f0906b7464ed94a8e7c5a5c6c346ebd72e957278b72627433cb3014028d02c1718fe468eee4e2aa
diff --git a/kde-frameworks/kauth/kauth-5.71.0.ebuild b/kde-frameworks/kauth/kauth-5.71.0.ebuild
new file mode 100644
index 000000000000..13409149547e
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.71.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package policykit PolkitQt5-1)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ ecm_src_test
+}