summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-11-17 06:03:26 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-11-17 06:03:53 +1100
commitd185c5cb325c0f23795538e1c25ae639c8e69040 (patch)
treefce2ac2182bbdc2fd982850cd177e801efe9bc14 /kde-frameworks/ki18n/ki18n-5.28.0.ebuild
parentkde-apps/kdeadmin-meta: Drop obsolete comment (diff)
downloadgentoo-d185c5cb325c0f23795538e1c25ae639c8e69040.tar.gz
gentoo-d185c5cb325c0f23795538e1c25ae639c8e69040.tar.bz2
gentoo-d185c5cb325c0f23795538e1c25ae639c8e69040.zip
kde-frameworks: version bump 5.28.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-frameworks/ki18n/ki18n-5.28.0.ebuild')
-rw-r--r--kde-frameworks/ki18n/ki18n-5.28.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/ki18n-5.28.0.ebuild b/kde-frameworks/ki18n/ki18n-5.28.0.ebuild
new file mode 100644
index 000000000000..c45c63346b63
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.28.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit kde5 python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(add_qt_dep qtscript)
+ sys-devel/gettext
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ test? ( $(add_qt_dep qtconcurrent) )
+"
+
+pkg_setup() {
+ kde5_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ kde5_src_install
+ python_fix_shebang "${ED}/usr/$(get_libdir)/cmake/KF5I18n/ts-pmap-compile.py"
+}