summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-10 14:15:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-11 23:00:24 +0100
commita37abaa67c24e28e5e853a9f9e8ed3381ceff877 (patch)
treee82c32cd1411c52fe9216880222174a0ef3c2bd9 /kde-frameworks/knotifications
parentapp-admin/keepassxc: updating 9999 for new build options and deps (diff)
downloadgentoo-a37abaa67c24e28e5e853a9f9e8ed3381ceff877.tar.gz
gentoo-a37abaa67c24e28e5e853a9f9e8ed3381ceff877.tar.bz2
gentoo-a37abaa67c24e28e5e853a9f9e8ed3381ceff877.zip
kde-frameworks: Add KDE Frameworks 5.43.0
Bug: https://bugs.gentoo.org/647306 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-frameworks/knotifications')
-rw-r--r--kde-frameworks/knotifications/Manifest1
-rw-r--r--kde-frameworks/knotifications/knotifications-5.43.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/knotifications/Manifest b/kde-frameworks/knotifications/Manifest
index 876997855e87..8e4e94998b64 100644
--- a/kde-frameworks/knotifications/Manifest
+++ b/kde-frameworks/knotifications/Manifest
@@ -1,2 +1,3 @@
DIST knotifications-5.40.0.tar.xz 99964 BLAKE2B 7ab0dfcca611b28f2f008fa7984a6b7b832ed718d54fd0cbf1b7b810d02ec89bc6f95fb2ffee1d877397ed68abeefdce113a879ad565e8af9cd892aa1fdddba6 SHA512 7fbeff7ce781904ae9d3d57ef439c1d41880558f219465d5b593ee3099d3ce091124067494f5ce9da590ce68ab8f12ac2eda96c59be8d0a767b3edafeb251675
DIST knotifications-5.42.0.tar.xz 100612 BLAKE2B d79562372d7f6e92bc209e3fb5a646d596da2767358e40fa91e02bd4958bd07085808d983497d56192ad4e3f0e46889d84d0a3d2d1b976e746be8afc75a331ac SHA512 7440bb4b4f025a80d5fc2ffdc10189c7223c0b82ec569f640b88e7fba4f84ccc00a4cbf59c3b31b102db2292ab9cd2ed612ca4c5acc5bf0d65860b891ebb3f14
+DIST knotifications-5.43.0.tar.xz 100596 BLAKE2B 6336ef154c418458ef93324978cc0bb7866ef638df872250387f765df0c57bef1b4ede8cefc7b81322318a9d0e03503dc98e3999852b3368f080902302b21396 SHA512 a90296cdcf557bba36185edda0da037e6a8bc069e5d2d7e3c4f7a692d0fcc8345fd28abed374ba25dd97c5e3f6834cd661d102629a1811b9e76285afac105c36
diff --git a/kde-frameworks/knotifications/knotifications-5.43.0.ebuild b/kde-frameworks/knotifications/knotifications-5.43.0.ebuild
new file mode 100644
index 000000000000..0ec118ecd131
--- /dev/null
+++ b/kde-frameworks/knotifications/knotifications-5.43.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework for notifying the user of an event"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="dbus nls speech X"
+
+RDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ media-libs/phonon[qt5(+)]
+ dbus? ( dev-libs/libdbusmenu-qt[qt5(+)] )
+ speech? ( $(add_qt_dep qtspeech) )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package dbus dbusmenu-qt5)
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}