summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-15 20:23:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-15 20:56:39 +0200
commit3f84f6af2f02d2e5d2f5031e1cf87441a1ff7b35 (patch)
tree15758c033bc1a4c5094e11212d2b24a52cb160c7 /kde-frameworks/plasma
parentkde-frameworks/plasma: Fix Plasma (non-Qt) icon scaling (diff)
downloadgentoo-3f84f6af2f02d2e5d2f5031e1cf87441a1ff7b35.tar.gz
gentoo-3f84f6af2f02d2e5d2f5031e1cf87441a1ff7b35.tar.bz2
gentoo-3f84f6af2f02d2e5d2f5031e1cf87441a1ff7b35.zip
kde-frameworks/plasma: Fix pinned calendar showing wrong no. of dots
Upstream commit 19fe24ef9377178413438d7749630053995af229 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=440627 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/plasma')
-rw-r--r--kde-frameworks/plasma/files/plasma-5.85.0-fix-pinned-calendar-dots.patch37
-rw-r--r--kde-frameworks/plasma/plasma-5.85.0-r1.ebuild5
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-frameworks/plasma/files/plasma-5.85.0-fix-pinned-calendar-dots.patch b/kde-frameworks/plasma/files/plasma-5.85.0-fix-pinned-calendar-dots.patch
new file mode 100644
index 000000000000..0342024ca89d
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.85.0-fix-pinned-calendar-dots.patch
@@ -0,0 +1,37 @@
+From 19fe24ef9377178413438d7749630053995af229 Mon Sep 17 00:00:00 2001
+From: Eugene Popov <popov895@ukr.net>
+Date: Mon, 9 Aug 2021 15:56:02 +0000
+Subject: [PATCH] [Calendar] Fix pinned calendar displaying the wrong number of
+ dots
+
+Use assignment instead of binding for the rootIndex property of the DelegateModel.
+
+BUG: 440627
+FIXED-IN: 5.86
+---
+ src/declarativeimports/calendar/qml/DayDelegate.qml | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/declarativeimports/calendar/qml/DayDelegate.qml b/src/declarativeimports/calendar/qml/DayDelegate.qml
+index af31991db..3f7fc681b 100644
+--- a/src/declarativeimports/calendar/qml/DayDelegate.qml
++++ b/src/declarativeimports/calendar/qml/DayDelegate.qml
+@@ -81,13 +81,14 @@ PlasmaComponents3.AbstractButton {
+ Repeater {
+ model: DelegateModel {
+ model: dayStyle.dayModel
+- rootIndex: modelIndex(index)
+ delegate: Rectangle {
+ width: PlasmaCore.Units.smallSpacing * 1.5
+ height: width
+ radius: width / 2
+ color: model.eventColor ? Kirigami.ColorUtils.linearInterpolation(model.eventColor, PlasmaCore.Theme.textColor, 0.2) : PlasmaCore.Theme.highlightColor
+ }
++
++ Component.onCompleted: rootIndex = modelIndex(index)
+ }
+ }
+ }
+--
+GitLab
+
diff --git a/kde-frameworks/plasma/plasma-5.85.0-r1.ebuild b/kde-frameworks/plasma/plasma-5.85.0-r1.ebuild
index 92d12a32c098..2051388092d6 100644
--- a/kde-frameworks/plasma/plasma-5.85.0-r1.ebuild
+++ b/kde-frameworks/plasma/plasma-5.85.0-r1.ebuild
@@ -61,7 +61,10 @@ DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
"
-PATCHES=( "${FILESDIR}"/${P}-fix-plasma-scaling-w-int-scale-factors.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-plasma-scaling-w-int-scale-factors.patch
+ "${FILESDIR}"/${P}-fix-pinned-calendar-dots.patch # KDE-bug 440627
+)
src_configure() {
local mycmakeargs=(