summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-17 10:50:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-18 00:00:49 +0100
commit9659c42be43a7660dab6a05586a10ed20d9c609c (patch)
tree71998bfc3e5adbe5a41c6a744c641baa8d00aac8 /kde-frameworks/purpose
parentkde-frameworks/kxmlgui: add 5.246.0 (diff)
downloadgentoo-9659c42be43a7660dab6a05586a10ed20d9c609c.tar.gz
gentoo-9659c42be43a7660dab6a05586a10ed20d9c609c.tar.bz2
gentoo-9659c42be43a7660dab6a05586a10ed20d9c609c.zip
kde-frameworks/purpose: add 5.246.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.246.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 574826a04cc0..9d80003a98b5 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.112.0.tar.xz 180816 BLAKE2B 4ed9e6fa546b8b230375ccbdab32e3bbfe79262204d94a9180b299903f499df94abd546ba68d8b43b29bfc3c7e101ff17e75bebc44ecd8ee1253a4e1e78ed5fc SHA512 b5cbcf29f2659dfb60891083abe516bb230a4ee5e67da88e4c231c7c0a5eac9ec076c71a7cbd4d6ba40ca79e45b1a8b422e636a91a1a67517f81ad98963584b3
DIST purpose-5.113.0.tar.xz 179544 BLAKE2B 9c9cf7d17f2c8b270f23052553796ea7403260bab11186ff846d840503efc9ae5fdc1d70730605584f7f14ea1aa9f7258864458f2b813b4ed7e01a466f818bbd SHA512 df7f2b3164caa474100731eb360318c2a6bb8301aeb0729fab3824d95f123ece00e74032c2533ce477c92717c116404ed56f7c320320557c29a5036ecf135f7e
+DIST purpose-5.246.0.tar.xz 179352 BLAKE2B d0fcf85f71164442457c6c04aeda1fcf7c18db7a5374829c3cff78b2ce47e01845d65fe96e062a5cb08b5c04db5dea5a161fe1172d78007a07c9dcc9c0414387 SHA512 a9035cf0e90d5a3841f9028b5f4d783e692135ac2ac5097dd27c05eccc2431b5445428b823ac4b3a74119dfd6922ae644da377ec064ced29db13283b9ba81b2e
diff --git a/kde-frameworks/purpose/purpose-5.246.0.ebuild b/kde-frameworks/purpose/purpose-5.246.0.ebuild
new file mode 100644
index 000000000000..4d859686c01c
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.246.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64"
+IUSE="bluetooth"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kio-${PVCUT}*:6
+ =kde-frameworks/kirigami-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kservice-${PVCUT}*:6
+ =kde-frameworks/prison-${PVCUT}*:6
+"
+# kaccounts? (
+# >=kde-apps/kaccounts-integration-19.04.3:6
+# net-libs/accounts-qt
+# )
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:5[-kf6compat(-)]
+ >=kde-frameworks/kdeclarative-${PVCUT}:6
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:6 )
+"
+# kaccounts? ( net-libs/accounts-qml )
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+# src_configure() {
+# local mycmakeargs=(
+# $(cmake_use_find_package kaccounts KAccounts)
+# )
+#
+# ecm_src_configure
+# }
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}