summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-25 23:23:38 +0100
committerSam James <sam@gentoo.org>2024-06-25 23:23:38 +0100
commit056d1cd7fe929fb27ff8eb942c949a7b31314a7c (patch)
tree0bdd5bd4df57dbead633e0ce8226a1c2ac4b4a6c /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 6.1.1 version bump (diff)
downloadgentoo-056d1cd7fe929fb27ff8eb942c949a7b31314a7c.tar.gz
gentoo-056d1cd7fe929fb27ff8eb942c949a7b31314a7c.tar.bz2
gentoo-056d1cd7fe929fb27ff8eb942c949a7b31314a7c.zip
kde-plasma/ksshaskpass: 6.1.1 version bump
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-6.1.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 43fca45e718d..6893fd85b7e6 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.27.11.tar.xz 27980 BLAKE2B 4fa35480f0ed7389bf41f56fc8266fccb8a33060c37f6df2c1edc44f49466267dbd45584e0afff6aaa79a3b5ffc1aca916c36a7ad768e36a457c081bfa53f217 SHA512 85c4091faa4ec4a6d068d4a0d464601054b88187ccfa05f4156b146dd3b3900dc15bcb3f9f9b0b057fb9b5687eabf55bb34d06d98a9e26ddb6a0afba1684feee
DIST ksshaskpass-6.1.0.tar.xz 29464 BLAKE2B d8b89ee96bed71b60ddbf132ee1ccad60487cd31933f7431b6c070bc6ea1b28f1480875c9f9e2ad858265f0bf475538398298f09ebd4a66f9dbe683af854c394 SHA512 2aa768e759436f51c47a0586085a887c441b564d3ff5fdad8b66214549059a4bf9862ab325a44fdadb5bc33de1c04603cc3642e6aca39566f957acaca7146990
+DIST ksshaskpass-6.1.1.tar.xz 29440 BLAKE2B 23eea8705a73efaea9685ca1135e25b0ac56d37086357cc7dd0acc370d4f563e45d84a54c413d05895af5dfbe720f76e08b0fe963d6bb7f6d4fd367a3297e9ad SHA512 282e02605a7929bd103bef77f930611209043b4d2c62ef90026013bc77f1f5deff361043bae9ed4d97e20ddd00d2d6752ab889eb6e309ca4d4ea0ff13502bd38
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-6.1.1.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-6.1.1.ebuild
new file mode 100644
index 000000000000..5d41c227a0f6
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-6.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.3.0
+QTMIN=6.7.1
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 6,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 6 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+}