summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-10 23:18:13 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-11 00:04:00 +0100
commitadc8c854698835fd181b5d708a0c6f9ec29284ad (patch)
treeea5465da587ea23c3e4106d533bcd2020e4876d5 /kde-plasma/ksshaskpass
parentkde-plasma/kscreenlocker: 5.92.0 version bump (diff)
downloadgentoo-adc8c854698835fd181b5d708a0c6f9ec29284ad.tar.gz
gentoo-adc8c854698835fd181b5d708a0c6f9ec29284ad.tar.bz2
gentoo-adc8c854698835fd181b5d708a0c6f9ec29284ad.zip
kde-plasma/ksshaskpass: 5.92.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.92.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 265506da8253..f0b64bbf6fa1 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.27.10.tar.xz 28044 BLAKE2B ba716a154ec0946d5e6b2dc340ce7c3dc8f84fdae52956661a4cd8aa142a977fd26bf99ea060f3834819b887ede03dca5d7d4112509384b3c1437709510e8076 SHA512 4e868547493904c79d37a9170e8d3fbce9e47ea762ae8c59507faab9517478b44cbb48cd2fa6c8bd9f9e41f74e57a859e127db258be2b7a643c6b68fecec4a31
DIST ksshaskpass-5.91.0.tar.xz 28864 BLAKE2B 5d7959a1c3bb2bdd4c791b0fceeb9d9ac783dbe296a0d50912b6a5205f30190d8ee73072e6323828297edb1244c4dab302a655e9782276088fa2ab39cd3bf007 SHA512 4d82f683ce5e979f3b2d4a51534664fbeb68e092333e622ae69268d8c618e71a90b183d24a38ba2b597308deaae535d5b64651e42ca35636b74d3f12724df79d
+DIST ksshaskpass-5.92.0.tar.xz 28884 BLAKE2B 5f129643a45947af70839ba01d5d43c38a3cd8ccf497d55d2e3d97f52984a790d4224d67afe62aa448bc1fe43bd9da64af2269e67232299b27420a7a0bca808a SHA512 c5627c61be098d143dcaf182560362f480fb3a121980ed716cc62930b221e56a64c5b16532ef42a0b329da5cc3bcc59c480ca4e4968033a62a48d71f2ae53d62
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.92.0.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.92.0.ebuild
new file mode 100644
index 000000000000..efb54062ff82
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.92.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.248.0
+QTMIN=6.6.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 6,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 6 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+}