summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 12:18:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 18:46:53 +0200
commit082f60ce272411b5028a2509f04697a1c558e93a (patch)
tree6f13a41ba2c718309c11eb06f3e608b5fdea617c /kde-plasma/plasma-firewall
parentkde-plasma/plasma-disks: 5.22.5 version bump (diff)
downloadgentoo-082f60ce272411b5028a2509f04697a1c558e93a.tar.gz
gentoo-082f60ce272411b5028a2509f04697a1c558e93a.tar.bz2
gentoo-082f60ce272411b5028a2509f04697a1c558e93a.zip
kde-plasma/plasma-firewall: 5.22.5 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-firewall')
-rw-r--r--kde-plasma/plasma-firewall/Manifest1
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-5.22.5.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/kde-plasma/plasma-firewall/Manifest b/kde-plasma/plasma-firewall/Manifest
index 3ee456091552..a0522bbce108 100644
--- a/kde-plasma/plasma-firewall/Manifest
+++ b/kde-plasma/plasma-firewall/Manifest
@@ -1,2 +1,3 @@
DIST plasma-firewall-5.21.5.tar.xz 331812 BLAKE2B 43a026a198fb61480e90c5a5235de1abbb106e3f78d4a81fe919ec8c65c4f5ca30b340436b28369d8797d9ad1eac87fd0a4e39b5e3670f68150992e6007c4a76 SHA512 93d36b12025f1918892ad02e6b92dc8c44c27d2c6426a19fb77d8b258940a25295acd923b3957d45eb1715dae097097368b0456bf27273c217b79b441dec55fd
DIST plasma-firewall-5.22.4.tar.xz 339068 BLAKE2B 3b3948e9905c448f36eba48af55983479dd4e72f4511033e445bf621cd9f2b3747ba1402611368974a6f19170b8f54207d397ed18e71fa11f2f13d87f4f5c41d SHA512 6863e369183d81d7ac381f0951dbf6b4c903b6ca1c5780c1bba80843b8f0650272059b1e3627762edb700162ac0488a3b07d159e86e78d1f0026f282815421fa
+DIST plasma-firewall-5.22.5.tar.xz 339372 BLAKE2B 332a7fd2be63429c452f43371b2875f8838e05b107a6c3472974c5db123eef9e415ec70601cb830a743d77422639225e01611e52c07a2b3fe079572278e2f638 SHA512 cc81884550b5c73061f5a1df24c0b32e5fff234a51e56153e95a9e4b0e23c305a555c2deff69633b9cd21dff7bfbcf5d9fcbd5ab3605d4ffa87be57514a91901
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-5.22.5.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-5.22.5.ebuild
new file mode 100644
index 000000000000..b8b3c53d50a4
--- /dev/null
+++ b/kde-plasma/plasma-firewall/plasma-firewall-5.22.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+KFMIN=5.82.0
+QTMIN=5.15.2
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Plasma frontend for Firewalld or UFW"
+HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="firewalld +ufw"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ firewalld? ( net-firewall/firewalld )
+ ufw? ( net-firewall/ufw )
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # this kind of cmake magic doesn't work for us at all.
+ sed -e "1 s:^.*$:\#\!/usr/bin/env python3.8:" \
+ -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
+ -DBUILD_UFW_BACKEND=$(usex ufw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}