summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-25 16:00:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-29 10:26:15 +0200
commit5da0293ca71c4608b453b99db6a9202db5e87143 (patch)
treedb667399d40199eeede6caae148812fc855b351c /kde-plasma/plasma-nm
parentapp-portage/eix: Fix C++ standard to C++14 to fix code bugs (diff)
downloadgentoo-5da0293ca71c4608b453b99db6a9202db5e87143.tar.gz
gentoo-5da0293ca71c4608b453b99db6a9202db5e87143.tar.bz2
gentoo-5da0293ca71c4608b453b99db6a9202db5e87143.zip
kde-plasma: Add KDE Plasma 5.12.7
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.12.7.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index d1b352a0ecdf..b1312edb42c5 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,3 +1,4 @@
DIST plasma-nm-5.12.5.tar.xz 703236 BLAKE2B f522d11a182b589beae46a2aae6c59b6964da7d073e8bae14464cd99fb29d9fc0188113a7a00ed568646daf7a22ef2000c3ccaee848361f50caaff6087364c40 SHA512 7c61743d028d27ead7b7c373757f5ea82703808702d31546477558a631607c15d867140624391b803a72f5675c96853e1eea07c7af3001718a96c36d6c3191c6
DIST plasma-nm-5.12.6.tar.xz 704664 BLAKE2B 5dd1741873d4b79a8d69d32065e95e9133244b01cce43e7242f07a4039e96cdbc93d864627cd6876f03a396da6d636cc877fe73fd879be14d65e839cf2b2e26d SHA512 aa1554ebf73bd0495722ebd58da5d12b6703335b6fa395f5a330911bbe563f113ed5fc3d78e20427b6af932da6e39faea539a6e6a1e3db9f61eb64bab7b62c60
+DIST plasma-nm-5.12.7.tar.xz 707240 BLAKE2B d6355e2a0ce181144842871c9335a02968d53f95d587f5d7fa982de33e64d6642a2ef450ba98052526f5114777f516daa801b42424e8bd48d65f3a334eca7aa3 SHA512 1727a113c2c48485d2864ca48d4bf7b05cec8fdeaf41bca2c6c0820a8f5665b77530b846eba4512aebe7c13362573154146f94538bee533c268781e70c462e56
DIST plasma-nm-5.13.5.tar.xz 705984 BLAKE2B 0a00bb3696ebc4ee5f26746cb1c1e9ef14e456abf448faf17d8ddb919f272354a88969ac54447ac626640d260c8bc1c4ffe3a578e3d2683c5efdf80d9b7d9a4b SHA512 13c0c5c27a5d01cf20093f314ff620658688fb10dfa052419b54f37e6de20fc947b120c7c9f3df5b3e8f3d92a1e701674c917456dbfb681c94e06a1da0456ead
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.12.7.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.12.7.ebuild
new file mode 100644
index 000000000000..9fa11048ffd4
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.12.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-misc/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/plasma-nm:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}