summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2016-09-14 00:36:19 +0200
committerHanno <hanno@gentoo.org>2016-09-14 00:36:19 +0200
commit55e7f9e76898ad4608bf8db4887a64d32d10eaa9 (patch)
tree0b379469017ef56618a23b1e3b57929fb2806e2c /lxde-base/lxrandr/lxrandr-0.3.1.ebuild
parentlxde-base/lxpanel: Version bump to 0.8.2 (diff)
downloadgentoo-55e7f9e76898ad4608bf8db4887a64d32d10eaa9.tar.gz
gentoo-55e7f9e76898ad4608bf8db4887a64d32d10eaa9.tar.bz2
gentoo-55e7f9e76898ad4608bf8db4887a64d32d10eaa9.zip
lxde-base/lxrandr: Version bump to 0.3.1
Also fix incorrect LICENSE (was GPL-3, should be GPL-2). Package-Manager: portage-2.3.0
Diffstat (limited to 'lxde-base/lxrandr/lxrandr-0.3.1.ebuild')
-rw-r--r--lxde-base/lxrandr/lxrandr-0.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/lxde-base/lxrandr/lxrandr-0.3.1.ebuild b/lxde-base/lxrandr/lxrandr-0.3.1.ebuild
new file mode 100644
index 000000000000..15b18295f0da
--- /dev/null
+++ b/lxde-base/lxrandr/lxrandr-0.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+DESCRIPTION="LXDE GUI interface to RandR extention"
+HOMEPAGE="http://lxde.org/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~arm-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXrandr
+ x11-apps/xrandr"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0"
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS
+}