summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-11 17:19:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-11 18:30:29 +0200
commit45ea3f63ca5e26a0806e7714ae2edbd832a681cc (patch)
tree15c2bdd2763c67aa2490c823e2d69b015839d346 /mail-mta
parentgames-strategy/freeciv: Fix build w/ USE=qt6 (diff)
downloadgentoo-45ea3f63ca5e26a0806e7714ae2edbd832a681cc.tar.gz
gentoo-45ea3f63ca5e26a0806e7714ae2edbd832a681cc.tar.bz2
gentoo-45ea3f63ca5e26a0806e7714ae2edbd832a681cc.zip
mail-mta/ssmtp: Fix build w/ GCC-14
Closes: https://bugs.gentoo.org/879873 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/ssmtp/files/ssmtp-2.64_p11-gcc14.patch43
-rw-r--r--mail-mta/ssmtp/ssmtp-2.64_p11-r1.ebuild4
2 files changed, 46 insertions, 1 deletions
diff --git a/mail-mta/ssmtp/files/ssmtp-2.64_p11-gcc14.patch b/mail-mta/ssmtp/files/ssmtp-2.64_p11-gcc14.patch
new file mode 100644
index 000000000000..a96f6a9ac4ad
--- /dev/null
+++ b/mail-mta/ssmtp/files/ssmtp-2.64_p11-gcc14.patch
@@ -0,0 +1,43 @@
+From 85acc260f11090415c0f94b7d726917d6a449018 Mon Sep 17 00:00:00 2001
+From: psykose <alice@ayaya.dev>
+Date: Wed, 19 Apr 2023 20:11:39 +0000
+Subject: main/ssmtp: fix int-conversion
+
+fixes -Werror=int-conversion
+--
+diff --git a/ssmtp.c b/ssmtp.c
+index af4d1e5..9a28320 100644
+--- a/ssmtp.c
++++ b/ssmtp.c
+@@ -55,21 +55,21 @@ bool_t use_oldauth = False; /* use old AUTH LOGIN username style */
+
+ #define ARPADATE_LENGTH 32 /* Current date in RFC format */
+ char arpadate[ARPADATE_LENGTH];
+-char *auth_user = (char)NULL;
+-char *auth_pass = (char)NULL;
+-char *auth_method = (char)NULL; /* Mechanism for SMTP authentication */
+-char *mail_domain = (char)NULL;
+-char *from = (char)NULL; /* Use this as the From: address */
++char *auth_user = NULL;
++char *auth_pass = NULL;
++char *auth_method = NULL; /* Mechanism for SMTP authentication */
++char *mail_domain = NULL;
++char *from = NULL; /* Use this as the From: address */
+ char *hostname;
+ char *mailhost = "mailhub";
+-char *minus_f = (char)NULL;
+-char *minus_F = (char)NULL;
++char *minus_f = NULL;
++char *minus_F = NULL;
+ char *gecos;
+-char *prog = (char)NULL;
++char *prog = NULL;
+ char *root = NULL;
+ char *tls_cert = "/etc/ssl/certs/ssmtp.pem"; /* Default Certificate */
+-char *uad = (char)NULL;
+-char *config_file = (char)NULL; /* alternate configuration file */
++char *uad = NULL;
++char *config_file = NULL; /* alternate configuration file */
+
+ headers_t headers, *ht;
+
diff --git a/mail-mta/ssmtp/ssmtp-2.64_p11-r1.ebuild b/mail-mta/ssmtp/ssmtp-2.64_p11-r1.ebuild
index 9aec3849e1e9..07226d8474a1 100644
--- a/mail-mta/ssmtp/ssmtp-2.64_p11-r1.ebuild
+++ b/mail-mta/ssmtp/ssmtp-2.64_p11-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -47,6 +47,8 @@ RDEPEND="
)
"
+PATCHES=( "${FILESDIR}"/${P}-gcc14.patch ) # bug 879873, from Alpine
+
src_prepare() {
drop_debian_patch() {
rm "${WORKDIR}"/debian/patches/${1} || die