summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2024-07-11 23:01:37 -0600
committerYixun Lan <dlan@gentoo.org>2024-07-12 10:40:57 +0000
commit8be012f31f96275dfddcecd73bbf2f856e5a1124 (patch)
tree1c898d0ac5e9a2b18a0d66b6a504ddb3aa84f653 /mail-mta
parentdev-python/qtconsole: Enable py3.13 (diff)
downloadgentoo-8be012f31f96275dfddcecd73bbf2f856e5a1124.tar.gz
gentoo-8be012f31f96275dfddcecd73bbf2f856e5a1124.tar.bz2
gentoo-8be012f31f96275dfddcecd73bbf2f856e5a1124.zip
mail-mta/msmtp: add 1.8.26
Closes: https://github.com/gentoo/gentoo/pull/37526 Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/msmtp/Manifest1
-rw-r--r--mail-mta/msmtp/msmtp-1.8.26.ebuild142
2 files changed, 143 insertions, 0 deletions
diff --git a/mail-mta/msmtp/Manifest b/mail-mta/msmtp/Manifest
index e0b2b11c81fc..a1b32bed5b91 100644
--- a/mail-mta/msmtp/Manifest
+++ b/mail-mta/msmtp/Manifest
@@ -1,2 +1,3 @@
DIST msmtp-1.8.24.tar.xz 409268 BLAKE2B 1661dffbdf9418665dfea3eacdcb716a27ea0916024247ccc221d0f6c3da0076f9bc3b822e9f0c152185f08b8d929268f8eaf63489304225d200a093fcff9d46 SHA512 9bcd1431bd27a74cea931da0e89adfdc53b5be027cef4a735e2fdaba3aed38408b4a266960b51a4071664b88b1af4545a3df5acf64b9ab8ce84000c49a8286ff
DIST msmtp-1.8.25.tar.xz 418264 BLAKE2B 1ba407a130849c7ba1f9959a88d368f8b8330b33be4eb612f3308afcf94e6e5fe010a844c3ff03e7b848cd60493c7a9f4ab6af18aed5a1fbf452ed7863f192f2 SHA512 7d9808b095b222f2283fb42395cb6560f776c9f92f9f467ea2245196b5dc8a85c359ff8c2ea68440e7eada8333a5da78aff921c2ef2b41cfde9d90c396425e72
+DIST msmtp-1.8.26.tar.xz 419644 BLAKE2B 55373fef589bc0cee8ad6091b4988b622e302ef1720c423b306bbfaa4b44fe59a8c6d7aeb9f32e672873a3f5b0f8f777c1c6c7729e84b3324e5f6812ee9b69a7 SHA512 36fa4a571079b0e1141e645f2a565f3c7699e1899f6ece66e3539bed595473488bdf147ed6ff1bff103c6240e484b2c357122292d5eae65ac4c0f74215eb556c
diff --git a/mail-mta/msmtp/msmtp-1.8.26.ebuild b/mail-mta/msmtp/msmtp-1.8.26.ebuild
new file mode 100644
index 000000000000..99d42c9e6537
--- /dev/null
+++ b/mail-mta/msmtp/msmtp-1.8.26.ebuild
@@ -0,0 +1,142 @@
+# Copyright 2004-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps
+
+DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
+HOMEPAGE="https://marlam.de/msmtp/"
+SRC_URI="https://marlam.de/msmtp/releases/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="daemon doc keyring +gnutls idn +mta nls sasl ssl"
+
+# fcaps.eclass unconditionally defines "filecaps" USE flag which we need for
+# USE="daemon" in order to set the caps we need.
+REQUIRED_USE="daemon? ( filecaps )"
+
+# Upstream discourages usage of openssl. See also
+# https://marlam.de/msmtp/news/openssl-discouraged/
+DEPEND="
+ idn? ( net-dns/libidn2:= )
+ nls? ( virtual/libintl )
+ keyring? ( app-crypt/libsecret )
+ sasl? ( net-misc/gsasl[client] )
+ ssl? (
+ gnutls? ( net-libs/gnutls[idn?] )
+ !gnutls? ( dev-libs/libretls:= )
+ )
+"
+
+RDEPEND="${DEPEND}
+ net-mail/mailbase
+ daemon? (
+ acct-group/msmtpd
+ acct-user/msmtpd
+ )
+ mta? (
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/postfix
+ !mail-mta/sendmail
+ !mail-mta/opensmtpd
+ !>=mail-mta/ssmtp-2.64-r2[mta]
+ )
+"
+
+BDEPEND="
+ doc? ( virtual/texi2dvi )
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS doc/msmtprc*"
+
+src_prepare() {
+ # Use default Gentoo location for mail aliases
+ sed 's:/etc/aliases:/etc/mail/aliases:' \
+ -i scripts/find_alias/find_alias_for_msmtp.sh || die
+
+ default
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-gai-idn
+ $(use_enable nls)
+ $(use_with daemon msmtpd)
+ $(use_with keyring libsecret)
+ $(use_with idn libidn)
+ $(use_with sasl libgsasl)
+ $(use_with ssl tls $(usex gnutls gnutls libtls))
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -C doc html pdf
+ fi
+}
+
+src_install() {
+ default
+
+ if use daemon ; then
+ fcaps CAP_NET_BIND_SERVICE usr/bin/msmtpd
+ newinitd "${FILESDIR}"/msmtpd.init msmtpd
+ newconfd "${FILESDIR}"/msmtpd.confd msmtpd
+ fi
+
+ if use doc ; then
+ dodoc doc/msmtp.{html,pdf}
+ fi
+
+ if use mta ; then
+ dosym ../bin/msmtp /usr/sbin/sendmail
+ dosym ../bin/msmtp /usr/$(get_libdir)/sendmail
+ fi
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins scripts/vim/msmtp.vim
+
+ insinto /etc
+ newins doc/msmtprc-system.example msmtprc
+
+ src_install_contrib find_alias find_alias_for_msmtp.sh
+ src_install_contrib msmtpqueue "*.sh" "README ChangeLog"
+ src_install_contrib msmtpq "msmtpq msmtp-queue" README.msmtpq
+ src_install_contrib set_sendmail set_sendmail.sh set_sendmail.conf
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ einfo "Please edit ${EROOT}/etc/msmtprc before first use."
+ einfo "In addition, per user configuration files can be placed"
+ einfo "as '~/.msmtprc'. See the msmtprc-user.example file under"
+ einfo "/usr/share/doc/${PF}/ for an example."
+ fi
+}
+
+src_install_contrib() {
+ subdir="$1"
+ bins="$2"
+ docs="$3"
+ local dir=/usr/share/${PN}/${subdir}
+ insinto ${dir}
+ exeinto ${dir}
+ for i in ${bins} ; do
+ doexe scripts/${subdir}/${i}
+ done
+ for i in ${docs} ; do
+ newdoc scripts/${subdir}/${i} ${subdir}.${i}
+ done
+}