summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-11-10 20:14:22 +0000
committerSam James <sam@gentoo.org>2024-11-26 03:14:36 +0000
commit1b705bd6955b6658ea3f662f53cdc44f904e8977 (patch)
treeda91d8ddca66d26eef7e8f78575c8375aa4281ea /mate-extra
parentmate-base/mate-panel: add 1.28.4 (diff)
downloadgentoo-1b705bd6955b6658ea3f662f53cdc44f904e8977.tar.gz
gentoo-1b705bd6955b6658ea3f662f53cdc44f904e8977.tar.bz2
gentoo-1b705bd6955b6658ea3f662f53cdc44f904e8977.zip
mate-extra/mate-system-monitor: add 1.28.1
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-system-monitor/Manifest1
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.28.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index aec7bf3e118a..2382728d8266 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1 +1,2 @@
DIST mate-system-monitor-1.28.0.tar.xz 2518132 BLAKE2B 375f89b87b79dac58a50ea139995872aa0cba208c9559d819d46e30dd3871d1d5d3bfdf6611e098daedc7e56d7f26ecefcf10b79c642740189a27900c6015b59 SHA512 238b2a2ac927cef78a67421499eaa983f875f90f0eeee4f1dcb175627784da2c2de24d2e8831f26f05779974a842962880a0dfb4eaf4e297ba41a5c1e82d9fce
+DIST mate-system-monitor-1.28.1.tar.xz 2521892 BLAKE2B d02c50f20be8b3c71e932f5e52ccb90a282dd4801a5ce89d06c62bc19be93d125ed0ea86693b81cd5406ac7ff8111bf9debeedd4cb77f0ba92697f268a310585 SHA512 0b3feea79836b00140b616c142cca1198c69ad201f652d0623fe319b9dcfb322893bfc9075c0869c6c6ff105ba2d67704a784db56e31263b8c82ea65e07978cc
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.28.1.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.28.1.ebuild
new file mode 100644
index 000000000000..33bee63b0332
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.28.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate toolchain-funcs
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="elogind systemd wnck"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.56:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.0:3
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/polkit-0.97:0
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.8
+ >=dev-build/autoconf-2.63:*
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=()
+
+ if use elogind || use systemd; then
+ myconf+=( --enable-systemd )
+ if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
+ myconf+=(
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags 'libelogind')"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs 'libelogind')"
+ )
+ fi
+ else
+ myconf+=( --disable-systemd )
+ fi
+
+ mate_src_configure "${myconf[@]}" \
+ $(use_enable wnck)
+}