summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:18:27 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:13 +0300
commita867b458692e16ab64675fa56bbfd70dec17a311 (patch)
treeef2bb883afb000c25161973c658f6b80436bd37e /mate-extra
parentmate-extra/mate-calc: drop 1.27.0-r1 (diff)
downloadgentoo-a867b458692e16ab64675fa56bbfd70dec17a311.tar.gz
gentoo-a867b458692e16ab64675fa56bbfd70dec17a311.tar.bz2
gentoo-a867b458692e16ab64675fa56bbfd70dec17a311.zip
mate-extra/mate-calc: add 1.28.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-calc/Manifest1
-rw-r--r--mate-extra/mate-calc/mate-calc-1.28.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/mate-extra/mate-calc/Manifest b/mate-extra/mate-calc/Manifest
index 4b1515e684b4..c9d7bd931646 100644
--- a/mate-extra/mate-calc/Manifest
+++ b/mate-extra/mate-calc/Manifest
@@ -1 +1,2 @@
DIST mate-calc-1.26.0.tar.xz 983272 BLAKE2B 92487951ac9bb55ef3d1fba80590b33ae750936f5ddf7b96fcec75c8008d9e06ab14149c4836ae9187fcba8f9d78184015bec7d4529356e3b2e11a3ebb7fac82 SHA512 142c496f8fcf1180f28e02b6a5d6d31ff00b7751783415c7d18e4086e316ca7d23ed0da0f9ecc0705773eb5e01f21e639f15d475aa1da1a7b5b03742ba45cb2f
+DIST mate-calc-1.28.0.tar.xz 1006168 BLAKE2B a89026a90a7b13cb64a85f67dc81acab434c721982f3cfcd7820e3097a97de6abfd157fedab01c0ab1237caddfe249bd0eecd8d391e72fa64fa163aa3241f5a9 SHA512 c4dfa7dcb8c6bb94ca0086e626833f144fd34c9362b556ab0402a39481096ce2047a3cfba1f69792af7673d94c01875d9b76f8178f38cc15c09cc98e4838bc55
diff --git a/mate-extra/mate-calc/mate-calc-1.28.0.ebuild b/mate-extra/mate-calc/mate-calc-1.28.0.ebuild
new file mode 100644
index 000000000000..f61ab3495336
--- /dev/null
+++ b/mate-extra/mate-calc/mate-calc-1.28.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+else
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Calculator for MATE"
+LICENSE="CC-BY-SA-3.0 GPL-2+"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ >=dev-libs/glib-2.50:2
+ dev-libs/libxml2:2
+ dev-libs/mpc:=
+ >=dev-libs/mpfr-4.0.2:=
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/pango
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+BDEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-libs/libxml2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"