summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:16:37 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:12 +0300
commitb8154a11ecd319f8152319268490775595ca82c5 (patch)
treed298dfb52212771caab0bde1742123419db495f0 /mate-extra
parentmate-extra/caja-dropbox: drop 1.27.0 (diff)
downloadgentoo-b8154a11ecd319f8152319268490775595ca82c5.tar.gz
gentoo-b8154a11ecd319f8152319268490775595ca82c5.tar.bz2
gentoo-b8154a11ecd319f8152319268490775595ca82c5.zip
mate-extra/caja-dropbox: add 1.28.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/caja-dropbox/Manifest1
-rw-r--r--mate-extra/caja-dropbox/caja-dropbox-1.28.0.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/mate-extra/caja-dropbox/Manifest b/mate-extra/caja-dropbox/Manifest
index 7b94ce841abc..d96d450dbf45 100644
--- a/mate-extra/caja-dropbox/Manifest
+++ b/mate-extra/caja-dropbox/Manifest
@@ -1 +1,2 @@
DIST caja-dropbox-1.26.0.tar.xz 361352 BLAKE2B 877196d1c6900904314e4ea0f4220821febe123395b1af8eb30e6557beea068ce572621473e733bf41f597a9c72d03ca0b2666cb7c335bbdcaefec06ffd577b9 SHA512 f96e3ddf4434936b04e992044d6cd5797b6ff77ead573e8e9a6493f4308d9716f47871f1fd7f08b0dbf7f2659f107511b6be65e98632a0892ebfff0a9888dbe7
+DIST caja-dropbox-1.28.0.tar.xz 375076 BLAKE2B baab500372a0c9616515c777998b1bfe7083aebe456ea0d67e7cdc3f515c71643c8a55651bacd120ec04393e5200483ab3cf669fd3015bdb57293f4c47e2f820 SHA512 3b6d4bf853066f9a8099d79226c598004d81230130d353f0c437f761b01fcef16748a57ffa2f0500c10f050ec4a8e79d647ae1f58425f5e83fc7568269af5f20
diff --git a/mate-extra/caja-dropbox/caja-dropbox-1.28.0.ebuild b/mate-extra/caja-dropbox/caja-dropbox-1.28.0.ebuild
new file mode 100644
index 000000000000..4f980b6e3511
--- /dev/null
+++ b/mate-extra/caja-dropbox/caja-dropbox-1.28.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10,11,12} )
+MATE_LA_PUNT="yes"
+
+inherit mate python-single-r1 linux-info
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Store, Sync and Share Files Online"
+LICENSE="CC-BY-ND-3.0 GPL-3+ public-domain"
+SLOT="0"
+
+IUSE="debug nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.46.0
+ >=dev-libs/glib-2.50:2
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ >=mate-base/caja-1.19.1
+ mate-extra/caja-extensions
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libXinerama
+ x11-libs/pango
+"
+
+RDEPEND="${COMMON_DEPEND}
+ net-misc/dropbox
+"
+
+BDEPEND="${COMMON_DEPEND}
+ dev-python/docutils
+ virtual/pkgconfig
+"
+
+CONFIG_CHECK="~INOTIFY_USER"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ check_extra_config
+}
+
+MATE_FORCE_AUTORECONF=true
+
+src_prepare() {
+ # Use system dropbox.
+ sed -e "s|~/[.]dropbox-dist|/opt/dropbox|" \
+ -e 's|\(DROPBOXD_PATH = \).*|\1"/opt/dropbox/dropboxd"|' \
+ -i caja-dropbox.in || die
+
+ sed -e 's|\[rst2man\]|\[rst2man\.py\]|' -i configure.ac || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable debug) \
+ $(use_enable nls)
+}
+
+src_install() {
+ python_fix_shebang caja-dropbox.in
+
+ mate_src_install
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" "-lt" "1.24.0-r1" || ver_test "${v}" "-eq" "9999"; then
+ ewarn "Starting with ${CATEGORY}/${PN}-1.24.0-r1, ${PN} now no longer"
+ ewarn "configures caja-dropbox to use its own group. This brings caja-dropbox in line"
+ ewarn "with nautilus-dropbox and dolphin-plugins-dropbox. You may remove the 'dropbox' group."
+ fi
+ done
+}