summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-05-22 12:08:59 +0000
committerJakov Smolić <jsmolic@gentoo.org>2023-05-22 16:55:24 +0200
commita48ddce30a6e83a2bac9a9febe5f1b09c7daa79d (patch)
treef4c0de8c91ee67ebf5a88346f3f61e4ccaa8ce0e /media-gfx/chafa
parentdev-libs/libuv: add 1.45.0 (diff)
downloadgentoo-a48ddce30a6e83a2bac9a9febe5f1b09c7daa79d.tar.gz
gentoo-a48ddce30a6e83a2bac9a9febe5f1b09c7daa79d.tar.bz2
gentoo-a48ddce30a6e83a2bac9a9febe5f1b09c7daa79d.zip
media-gfx/chafa: add 1.12.5
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/31124 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'media-gfx/chafa')
-rw-r--r--media-gfx/chafa/Manifest1
-rw-r--r--media-gfx/chafa/chafa-1.12.5.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/chafa/Manifest b/media-gfx/chafa/Manifest
index 90e03342e843..86365e27deeb 100644
--- a/media-gfx/chafa/Manifest
+++ b/media-gfx/chafa/Manifest
@@ -1 +1,2 @@
DIST chafa-1.12.4.tar.xz 934272 BLAKE2B 57009e5b6c8cbb41643e94d224e9a4a7e3c2839ee79a6d4949b6d872ab9e10ab66fe7a609f448cad68ee930e5da84e31a1368c8f7ad6457c4c1583971f87f91e SHA512 2732ff380fc6d61124298ae3d9958d676fe6ca2887ee11df057d4efa6f4ae9c074a7e1920a6a3db1ffb21882432769967f4453d52a0344e581993984133a0e9b
+DIST chafa-1.12.5.tar.xz 939792 BLAKE2B 82fbcd7b071dba8534fdd391b6ce22f6de63b1e3eb30228ba1ce6e751c442efbc4a5141d30fa767cc0789b01518da016a4245f9c560837530daa4d92534a9eca SHA512 d0b719294bdc8880f2c65c1bd777ac0eb98d47d48147bc6f883f1917d4f9a6b246c4e9365bc0128b1332d4a268611ac7e479f346f13c49d2e56ff4f446f22d94
diff --git a/media-gfx/chafa/chafa-1.12.5.ebuild b/media-gfx/chafa/chafa-1.12.5.ebuild
new file mode 100644
index 000000000000..8282650592c2
--- /dev/null
+++ b/media-gfx/chafa/chafa-1.12.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
+HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
+SRC_URI="https://hpjansson.org/chafa/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="+tools"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/imagemagick:0=
+ tools? ( >=media-libs/freetype-2.0.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-man \
+ $(use_with tools)
+}
+
+src_install() {
+ local DOCS=( AUTHORS NEWS README TODO )
+ default
+
+ use tools && doman docs/chafa.1
+
+ find "${ED}" -name '*.la' -delete || die
+}