summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-15 14:56:53 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-16 13:40:27 -0400
commit4f12ad3e6c3bf847ce8ac349927cf64ecabcb03b (patch)
tree153d7779876be104541ba6a86249ee9a71e82b77 /media-gfx/eog
parentnet-fs/samba: Stabilize 4.16.8 ppc64, #893086 (diff)
downloadgentoo-4f12ad3e6c3bf847ce8ac349927cf64ecabcb03b.tar.gz
gentoo-4f12ad3e6c3bf847ce8ac349927cf64ecabcb03b.tar.bz2
gentoo-4f12ad3e6c3bf847ce8ac349927cf64ecabcb03b.zip
media-gfx/eog: Version bump to 44_beta
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30141 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx/eog')
-rw-r--r--media-gfx/eog/Manifest1
-rw-r--r--media-gfx/eog/eog-44_beta.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/media-gfx/eog/Manifest b/media-gfx/eog/Manifest
index 5183c27feb54..ab530e068003 100644
--- a/media-gfx/eog/Manifest
+++ b/media-gfx/eog/Manifest
@@ -1 +1,2 @@
DIST eog-43.2.tar.xz 4655416 BLAKE2B 9909fc3da58541191b25959be20e53987f5633c97e003b0c97c4029a7cd6084d3675d75584664a023ca45897982d3cfe2668b6dc94a34b22a249b15a87307470 SHA512 aa3bb2e2684140f6a35770f6f6b80f64f09ff0f36f25ddc561c9cbbf6f22fdb4bbb1a48392a29d59dcf4852c224146ac847c62c8196e9198b34e7015bf4bb760
+DIST eog-44.beta.tar.xz 4654948 BLAKE2B 30965b2d0f7fb6e82e6f151e0e64cb8c9898129d1a4918427b828a4bef413bed1b51bf24a79d34148cd7755649d992ab294c3de24e8bc5c5a97ec150a832220a SHA512 ba9732a99e2ab68c32c898cff8c2edecc585eb1bf16756164dd0fff94a5552e93f8cbf63cf8cea5cc36a3b1785cfc77ef7573892f5a653b897d9b13118b03bab
diff --git a/media-gfx/eog/eog-44_beta.ebuild b/media-gfx/eog/eog-44_beta.ebuild
new file mode 100644
index 000000000000..9e22758fd120
--- /dev/null
+++ b/media-gfx/eog/eog-44_beta.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="The Eye of GNOME image viewer"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome https://gitlab.gnome.org/GNOME/eog"
+SRC_URI="https://download.gnome.org/sources/${PN}/44/${PN}-44.beta.tar.xz"
+S="${WORKDIR}/${PN}-44.beta"
+
+LICENSE="GPL-2+"
+SLOT="1"
+
+IUSE="+exif gtk-doc +introspection +jpeg lcms +svg xmp tiff"
+REQUIRED_USE="
+ exif? ( jpeg )
+ gtk-doc? ( introspection )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.53.4:2
+ >=dev-libs/libpeas-0.7.4[gtk]
+ >=gnome-base/gnome-desktop-2.91.2:3=
+ >=gnome-base/gsettings-desktop-schemas-42_beta
+ >=x11-misc/shared-mime-info-0.20
+ >=x11-libs/gdk-pixbuf-2.36.5:2[jpeg?,tiff?]
+ >=x11-libs/gtk+-3.24.15:3[introspection,X]
+ >=gui-libs/libhandy-1.5.0:1
+ sys-libs/zlib
+
+ exif? ( >=media-libs/libexif-0.6.14 )
+ lcms? ( media-libs/lcms:2 )
+ xmp? ( media-libs/exempi:2= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ svg? ( >=gnome-base/librsvg-2.44.0:2 )
+
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? (
+ dev-util/gi-docgen
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif libexif)
+ $(meson_use lcms cms)
+ $(meson_use xmp)
+ $(meson_use jpeg libjpeg)
+ $(meson_use svg librsvg)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ -Dinstalled_tests=false
+ -Dlibportal=false # As of 40.3, all libportal usages are flatpak-specific
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}