summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-09-10 09:04:25 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-09-10 09:04:25 +0200
commit52fc47e8c7532de3562a64f8c76447d3f317b920 (patch)
tree41445ff2e6ca5240b62fd705ea85d20756b88cdd /media-gfx/exact-image
parentsys-kernel/vanilla-sources: Automated version bump to {4.14.197,4.19.144,5.4.... (diff)
downloadgentoo-52fc47e8c7532de3562a64f8c76447d3f317b920.tar.gz
gentoo-52fc47e8c7532de3562a64f8c76447d3f317b920.tar.bz2
gentoo-52fc47e8c7532de3562a64f8c76447d3f317b920.zip
media-gfx/exact-image: fix build with llvm
Closes: https://bugs.gentoo.org/739976 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'media-gfx/exact-image')
-rw-r--r--media-gfx/exact-image/exact-image-1.0.2.ebuild1
-rw-r--r--media-gfx/exact-image/files/exact-image-1.0.2-dcraw.patch11
2 files changed, 12 insertions, 0 deletions
diff --git a/media-gfx/exact-image/exact-image-1.0.2.ebuild b/media-gfx/exact-image/exact-image-1.0.2.ebuild
index 0cea0d26cf53..2c2e93b4fffd 100644
--- a/media-gfx/exact-image/exact-image-1.0.2.ebuild
+++ b/media-gfx/exact-image/exact-image-1.0.2.ebuild
@@ -39,6 +39,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-gcc6.patch
"${FILESDIR}"/${P}-g++.patch
+ "${FILESDIR}"/${P}-dcraw.patch
)
src_prepare() {
diff --git a/media-gfx/exact-image/files/exact-image-1.0.2-dcraw.patch b/media-gfx/exact-image/files/exact-image-1.0.2-dcraw.patch
new file mode 100644
index 000000000000..ba609c294b17
--- /dev/null
+++ b/media-gfx/exact-image/files/exact-image-1.0.2-dcraw.patch
@@ -0,0 +1,11 @@
+--- a/codecs/dcraw.h 2020-09-10 08:42:19.905105346 +0200
++++ b/codecs/dcraw.h 2020-09-10 08:47:50.826316874 +0200
+@@ -9956,7 +9956,7 @@
+ strncpy (th->desc, desc, 512);
+ strncpy (th->make, make, 64);
+ strncpy (th->model, model, 64);
+- strcpy (th->soft, "dcraw v"DCRAW_VERSION);
++ strcpy (th->soft, "dcraw v" DCRAW_VERSION);
+ t = localtime (&timestamp);
+ sprintf (th->date, "%04d:%02d:%02d %02d:%02d:%02d",
+ t->tm_year+1900,t->tm_mon+1,t->tm_mday,t->tm_hour,t->tm_min,t->tm_sec);