summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/gnome-photos/gnome-photos-3.16.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/gnome-photos/gnome-photos-3.16.2.ebuild')
-rw-r--r--media-gfx/gnome-photos/gnome-photos-3.16.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-gfx/gnome-photos/gnome-photos-3.16.2.ebuild b/media-gfx/gnome-photos/gnome-photos-3.16.2.ebuild
new file mode 100644
index 000000000000..fac1f6a9c4d2
--- /dev/null
+++ b/media-gfx/gnome-photos/gnome-photos-3.16.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="Access, organize and share your photos on GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Photos"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=app-misc/tracker-1:=
+ >=dev-libs/glib-2.39.3:2
+ gnome-base/gnome-desktop:3=
+ >=gnome-base/librsvg-2.26.0
+ >=dev-libs/libgdata-0.15.2:0=
+ media-libs/babl
+ >=media-libs/gegl-0.3:0.3
+ >=media-libs/grilo-0.2.6:0.2
+ >=media-plugins/grilo-plugins-0.2.6:0.2[upnp-av]
+ >=media-libs/exempi-1.99.5
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.14
+ >=net-libs/gnome-online-accounts-3.8
+ >=net-libs/libgfbgraph-0.2.1:0.2
+ >=x11-libs/cairo-1.14
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.15.5:3
+"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.50.1
+ virtual/pkgconfig
+ test? ( dev-util/dogtail )
+"
+# eautoreconf
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable test dogtail) \
+ ITSTOOL=$(type -P true)
+}
+
+src_test() {
+ Xemake check
+}