summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-09-25 17:58:37 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-09-25 17:58:57 +0200
commita0c757b987c124e1e3b6764488985105432282d4 (patch)
treeac6bdd622020087200000ce65bee5cd44cff7789 /media-gfx/inkscape/inkscape-1.1.ebuild
parentmedia-gfx/inkscape: add 1.1 (diff)
downloadgentoo-a0c757b987c124e1e3b6764488985105432282d4.tar.gz
gentoo-a0c757b987c124e1e3b6764488985105432282d4.tar.bz2
gentoo-a0c757b987c124e1e3b6764488985105432282d4.zip
media-gfx/inkscape: various minor fixups
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'media-gfx/inkscape/inkscape-1.1.ebuild')
-rw-r--r--media-gfx/inkscape/inkscape-1.1.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/media-gfx/inkscape/inkscape-1.1.ebuild b/media-gfx/inkscape/inkscape-1.1.ebuild
index 642643d65ca8..e62f8efdec2c 100644
--- a/media-gfx/inkscape/inkscape-1.1.ebuild
+++ b/media-gfx/inkscape/inkscape-1.1.ebuild
@@ -10,12 +10,15 @@ inherit cmake flag-o-matic xdg toolchain-funcs python-single-r1
DESCRIPTION="SVG based generic vector-drawing program"
HOMEPAGE="https://inkscape.org/"
-SRC_URI="https://media.inkscape.org/dl/resources/file/${P}.tar.xz"
+SRC_URI="
+ https://media.inkscape.org/dl/resources/file/${P}.tar.xz
+ https://dev.gentoo.org/~dilfridge/distfiles/inkscape-1.1-musl.txz
+"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="cdr dbus dia exif graphicsmagick imagemagick inkjar jemalloc jpeg lcms
+IUSE="cdr dbus dia exif graphicsmagick imagemagick inkjar jemalloc jpeg
openmp postscript readline spell static-libs svg2 visio wpg"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -43,6 +46,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
media-gfx/potrace
media-libs/fontconfig
media-libs/freetype:2
+ media-libs/lcms:2
media-libs/libpng:0=
net-libs/libsoup:2.4
sci-libs/gsl:=
@@ -66,7 +70,6 @@ COMMON_DEPEND="${PYTHON_DEPS}
)
jemalloc? ( dev-libs/jemalloc )
jpeg? ( virtual/jpeg:0 )
- lcms? ( media-libs/lcms:2 )
readline? ( sys-libs/readline:= )
spell? ( app-text/gspell )
visio? (
@@ -98,10 +101,6 @@ RESTRICT="test"
S="${WORKDIR}/${P}_2021-05-24_c4e8f9ed74"
-PATCHES=(
- "${FILESDIR}/${P}-sentinels.patch" # 1.1 is the last affected version, it is already fixed in upstream
-)
-
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
tc-has-openmp || die "Please switch to an openmp compatible compiler"
@@ -109,6 +108,9 @@ pkg_pretend() {
}
src_prepare() {
+ # Backport from master
+ eapply "${WORKDIR}/inkscape-1.1-musl/"*.patch
+
cmake_src_prepare
sed -i "/install.*COPYING/d" CMakeScripts/ConfigCPack.cmake || die
}
@@ -131,7 +133,7 @@ src_configure() {
-DWITH_GNU_READLINE=$(usex readline)
-DWITH_GSPELL=$(usex spell)
-DWITH_JEMALLOC=$(usex jemalloc)
- -DENABLE_LCMS=$(usex lcms)
+ -DENABLE_LCMS=ON
-DWITH_OPENMP=$(usex openmp)
-DBUILD_SHARED_LIBS=$(usex !static-libs)
-DWITH_SVG2=$(usex svg2)