summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 03:54:31 +0100
committerSam James <sam@gentoo.org>2022-05-31 03:54:37 +0100
commit0773c4063cede3878b29a6aaf54ee2596a358105 (patch)
treec1cdee81280eeaed53f5d51c24e30ca250a5ebe0 /media-gfx/inkscape
parentmedia-gfx/inkscape: sync live (diff)
downloadgentoo-0773c4063cede3878b29a6aaf54ee2596a358105.tar.gz
gentoo-0773c4063cede3878b29a6aaf54ee2596a358105.tar.bz2
gentoo-0773c4063cede3878b29a6aaf54ee2596a358105.zip
media-gfx/inkscape: skip some tests; fix SRC_URI
Bug: https://bugs.gentoo.org/846893 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/inkscape')
-rw-r--r--media-gfx/inkscape/inkscape-1.2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/media-gfx/inkscape/inkscape-1.2.ebuild b/media-gfx/inkscape/inkscape-1.2.ebuild
index 5e052cb10ba3..05ed4ec9c216 100644
--- a/media-gfx/inkscape/inkscape-1.2.ebuild
+++ b/media-gfx/inkscape/inkscape-1.2.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} = 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/inkscape/inkscape.git"
else
- SRC_URI="https://media.inkscape.org/dl/resources/file/${P}_2022-05-15_dc2aedaf03.tar.xz -> ${P}.tar.xz"
+ SRC_URI="https://media.inkscape.org/dl/resources/file/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
@@ -159,7 +159,15 @@ src_configure() {
}
src_test() {
- cmake_build -j1 check
+ local myctestargs=(
+ # render_text*: needs patched Cairo / maybe upstream changes
+ # not yet in a release.
+ # test_lpe/test_lpe64: precision differences b/c of new GCC?
+ # cli_export-png-color-mode-gray-8_png_check_output: ditto?
+ -E "(render_test-use|render_test-glyph-y-pos|render_text-glyphs-combining|render_text-glyphs-vertical|render_test-rtl-vertical|test_lpe|test_lpe64|cli_export-png-color-mode-gray-8_png_check_output)"
+ )
+
+ cmake_src_test -j1
}
src_install() {