summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/iscan-plugin-esdip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/iscan-plugin-esdip')
-rw-r--r--media-gfx/iscan-plugin-esdip/Manifest2
-rw-r--r--media-gfx/iscan-plugin-esdip/iscan-plugin-esdip-1.0.0.5-r1.ebuild42
-rw-r--r--media-gfx/iscan-plugin-esdip/metadata.xml14
3 files changed, 58 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-esdip/Manifest b/media-gfx/iscan-plugin-esdip/Manifest
new file mode 100644
index 000000000000..0b67deb84c66
--- /dev/null
+++ b/media-gfx/iscan-plugin-esdip/Manifest
@@ -0,0 +1,2 @@
+DIST iscan-plugin-esdip-1.0.0-5.ltdl7.i386.rpm 1311240 SHA256 2f30cd6b30193c5eda0f94ee1cd9204fe8427507802bd095a790f33a5a0a1bec SHA512 cff826ad66e1718a9b59f09849522af70789f782e36d5ed979ef4296eee7be5e4e02375c939300b94d6ac555f1db2441bee59758a8a0d040770d25b47ba8dbab WHIRLPOOL 5326584ff96e4c779d611db15913f43176484067b03d3cd2b59e615ac85fb777198b15150a338f1abf7009178d6c16d624d572f1fa8efda3db1c5a95d4567cac
+DIST iscan-plugin-esdip-1.0.0-5.ltdl7.x86_64.rpm 1359799 SHA256 fb17948a12f34e943613484ca9d05c80806cab34bd28dbcfe3ff593363b2ddd4 SHA512 3d5f9721eb9d8b56d16800a4a4a25c4b887d593e08d1d0c3709f10b92c52b906000e84c99f41eec13b9ccdbaf53d2621f6f1582d69a1e5e291239a47987776a7 WHIRLPOOL 88d747fcbe29a859326029584bb25c630217a1159aaca8ca9e7bdfc9e6782e758040b0da2a0e8b9c6fa73677eb11516ed9f21865bc13ce656362044dd814803a
diff --git a/media-gfx/iscan-plugin-esdip/iscan-plugin-esdip-1.0.0.5-r1.ebuild b/media-gfx/iscan-plugin-esdip/iscan-plugin-esdip-1.0.0.5-r1.ebuild
new file mode 100644
index 000000000000..bac88e3b78c1
--- /dev/null
+++ b/media-gfx/iscan-plugin-esdip/iscan-plugin-esdip-1.0.0.5-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit rpm versionator multilib
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+
+DESCRIPTION="Plugin for 'epkowa' backend for image manipulation"
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=L"
+SRC_URI="amd64? ( http://dev.gentoo.org/~flameeyes/avasys/${PN}-${MY_PVR}.ltdl7.x86_64.rpm )
+ x86? ( http://dev.gentoo.org/~flameeyes/avasys/${PN}-${MY_PVR}.ltdl7.i386.rpm )"
+
+LICENSE="AVASYS"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=media-gfx/iscan-2.28.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/lib64/iscan/libesdtr.so.0*
+ /usr/lib64/iscan/libesdtr2.so.0*"
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ dodoc usr/share/doc/*/*
+
+ exeinto /usr/$(get_libdir)/iscan
+ doexe usr/$(get_libdir)/iscan/*
+
+ insinto /usr/share/iscan
+ doins usr/share/iscan/*
+}
diff --git a/media-gfx/iscan-plugin-esdip/metadata.xml b/media-gfx/iscan-plugin-esdip/metadata.xml
new file mode 100644
index 000000000000..d036a9eed73b
--- /dev/null
+++ b/media-gfx/iscan-plugin-esdip/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Proprietary plugin for several EPSON scanner models, to be used
+ with the epkowa SANE backend (provided by
+ <pkg>media-gfx/iscan</pkg>). 32-bit and 64-bit.
+
+ Provides support for image manipulation (deskew and autocrop).
+ </longdescription>
+</pkgmetadata>