summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-25 03:51:46 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-25 03:58:25 -0500
commitc679b6bcbc3a675f7bfbdb703cea0689af6d73f8 (patch)
treecc3b7182440a40b6d65ab71e734cae9c859a23a6 /media-gfx/jpegoptim
parentmail-mta/postfix: add 3.10_pre20241122, drop 3.10_pre20241113 (diff)
downloadgentoo-c679b6bcbc3a675f7bfbdb703cea0689af6d73f8.tar.gz
gentoo-c679b6bcbc3a675f7bfbdb703cea0689af6d73f8.tar.bz2
gentoo-c679b6bcbc3a675f7bfbdb703cea0689af6d73f8.zip
media-gfx/jpegoptim: avoid broken/dated getopt.c with musl
*Should* fix bug #944902 but lazily haven't actually tried gcc15+musl given my ready-to-use musl chroot is llvm-musl. Did try it with glibc and gcc-15 is fine as-is though. Closes: https://bugs.gentoo.org/944902 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-gfx/jpegoptim')
-rw-r--r--media-gfx/jpegoptim/jpegoptim-1.5.5.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-gfx/jpegoptim/jpegoptim-1.5.5.ebuild b/media-gfx/jpegoptim/jpegoptim-1.5.5.ebuild
index 46f1697664d6..76927fefe6ac 100644
--- a/media-gfx/jpegoptim/jpegoptim-1.5.5.ebuild
+++ b/media-gfx/jpegoptim/jpegoptim-1.5.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Utility to optimize JPEG files"
HOMEPAGE="https://www.kokkonen.net/tjko/projects.html"
@@ -23,6 +23,8 @@ PATCHES=(
)
src_configure() {
+ use elibc_musl && append-cppflags -D__GNU_LIBRARY__ #944902
+
local mycmakeargs=(
-DUSE_MOZJPEG=no
)