summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2022-03-07 08:29:14 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-11 10:31:00 +0200
commitdbc303b62abba2c47f200be679d33784d6f9beae (patch)
tree3fd3802c7327cf4256ad0f9b91e4fb4a31d56730 /media-gfx/libimagequant
parentsys-cluster/lmod: version bump to 8.6.14 (diff)
downloadgentoo-dbc303b62abba2c47f200be679d33784d6f9beae.tar.gz
gentoo-dbc303b62abba2c47f200be679d33784d6f9beae.tar.bz2
gentoo-dbc303b62abba2c47f200be679d33784d6f9beae.zip
media-gfx/libimagequant: remove unused patches
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24434 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/libimagequant')
-rw-r--r--media-gfx/libimagequant/files/libimagequant-2.12.2-fix-pkgconfig.patch21
-rw-r--r--media-gfx/libimagequant/files/libimagequant-2.14.0-fix-openmp-pragma.patch18
2 files changed, 0 insertions, 39 deletions
diff --git a/media-gfx/libimagequant/files/libimagequant-2.12.2-fix-pkgconfig.patch b/media-gfx/libimagequant/files/libimagequant-2.12.2-fix-pkgconfig.patch
deleted file mode 100644
index ce9cc2b8c99f..000000000000
--- a/media-gfx/libimagequant/files/libimagequant-2.12.2-fix-pkgconfig.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -133,7 +133,7 @@ ifeq ($(filter %clean %distclean, $(MAKECMDGOALS)), )
- endif
-
- $(PKGCONFIG): config.mk
-- sed 's|PREFIX|$(PREFIX)|;s|VERSION|$(VERSION)|' < imagequant.pc.in > $(PKGCONFIG)
-+ sed 's|PREFIX|$(PREFIX)|;s|VERSION|$(VERSION)|;s|LIBDIR|$(LIBDIR)|' < imagequant.pc.in > $(PKGCONFIG)
-
- .PHONY: all static shared clean dist distclean dll java cargo
- .DELETE_ON_ERROR:
---- a/imagequant.pc.in
-+++ b/imagequant.pc.in
-@@ -1,6 +1,6 @@
- prefix=PREFIX
- includedir=${prefix}/include
--libdir=${prefix}/lib
-+libdir=LIBDIR
-
- Name: imagequant
- Description: Small, portable C library for high-quality conversion of RGBA images to 8-bit indexed-color (palette) images.
diff --git a/media-gfx/libimagequant/files/libimagequant-2.14.0-fix-openmp-pragma.patch b/media-gfx/libimagequant/files/libimagequant-2.14.0-fix-openmp-pragma.patch
deleted file mode 100644
index f355453ece6c..000000000000
--- a/media-gfx/libimagequant/files/libimagequant-2.14.0-fix-openmp-pragma.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-From 44525d34b738f733a81037286ece603ca0fdcf10 Mon Sep 17 00:00:00 2001
-From: Kornel <kornel@geekhood.net>
-Date: Wed, 27 Jan 2021 17:36:33 +0000
-Subject: [PATCH] Update OMP pragma
---- a/libimagequant.c
-+++ b/libimagequant.c
-@@ -1279,10 +1279,7 @@ LIQ_NONNULL static float remap_to_palette(liq_image *const input_image, unsigned
-
- #if __GNUC__ >= 9 || __clang__
- #pragma omp parallel for if (rows*cols > 3000) \
-- schedule(static) default(none) shared(acolormap,average_color,cols,input_image,map,n,output_pixels,rows,transparent_index) reduction(+:remapping_error)
--#else
-- #pragma omp parallel for if (rows*cols > 3000) \
-- schedule(static) default(none) shared(acolormap) shared(average_color) reduction(+:remapping_error)
-+ schedule(static) default(none) shared(background,acolormap,average_color,cols,input_image,map,n,output_pixels,rows,transparent_index) reduction(+:remapping_error)
- #endif
- for(int row = 0; row < rows; ++row) {
- const f_pixel *const row_pixels = liq_image_get_row_f(input_image, row);