summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/meshlab/meshlab-1.3.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/meshlab/meshlab-1.3.2.ebuild')
-rw-r--r--media-gfx/meshlab/meshlab-1.3.2.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/media-gfx/meshlab/meshlab-1.3.2.ebuild b/media-gfx/meshlab/meshlab-1.3.2.ebuild
new file mode 100644
index 000000000000..c5514d682ca5
--- /dev/null
+++ b/media-gfx/meshlab/meshlab-1.3.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator multilib qt4-r2
+
+DESCRIPTION="A mesh processing system"
+HOMEPAGE="http://meshlab.sourceforge.net/"
+MY_PV="$(delete_all_version_separators ${PV})"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/MeshLab%20v${PV}/MeshLabSrc_AllInc_v${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="dev-cpp/eigen:3
+ dev-cpp/muParser
+ dev-qt/qtcore:4
+ dev-qt/qtopengl:4
+ media-libs/glew
+ media-libs/qhull
+ =media-libs/lib3ds-1*
+ media-libs/openctm
+ sci-libs/levmar
+ sys-libs/libunwind"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/meshlab/src"
+
+src_prepare() {
+ rm "${WORKDIR}"/meshlab/src/distrib/plugins/*.xml
+ rm "${WORKDIR}"/meshlab/src/meshlabplugins/filter_qhull/qhull_tools.h
+ cd ${PORTAGE_BUILDDIR}
+ #patches from debian repo
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${PV}"/01_crash-on-save.patch \
+ "${FILESDIR}/${PV}"/02_cstddef.patch \
+ "${FILESDIR}/${PV}"/03_disable-updates.patch \
+ "${FILESDIR}/${PV}"/05_externals.patch \
+ "${FILESDIR}/${PV}"/06_format-security.patch \
+ "${FILESDIR}/${PV}"/07_gcc47.patch \
+ "${FILESDIR}/${PV}"/08_lib3ds.patch \
+ "${FILESDIR}/${PV}"/09_libbz2.patch \
+ "${FILESDIR}/${PV}"/10_muparser.patch \
+ "${FILESDIR}/${PV}"/11_openctm.patch \
+ "${FILESDIR}/${PV}"/12_overflow.patch \
+ "${FILESDIR}/${PV}"/13_pluginsdir.patch \
+ "${FILESDIR}/${PV}"/14_ply_numeric.patch \
+ "${FILESDIR}/${PV}"/15_qhull.patch \
+ "${FILESDIR}/${PV}"/16_shadersdir.patch \
+ "${FILESDIR}/${PV}"/17_structuresynth.patch \
+ "${FILESDIR}/${PV}"/18_glew.c18p1.patch \
+ "${FILESDIR}/${PV}"/19_CONFLICTS_IN_rpath.patch \
+ "${FILESDIR}/${PV}"/20_rpath.c18p2.patch \
+ "${FILESDIR}/${PV}"/21_RESOLUTION.patch \
+ "${FILESDIR}/${PV}"/22_aliasing.patch
+}
+
+src_configure() {
+ eqmake4 external/external.pro
+ eqmake4 meshlab_full.pro
+}
+
+src_compile() {
+ cd external && emake
+ cd .. && emake
+}
+
+src_install() {
+ dobin distrib/{meshlab,meshlabserver}
+ dolib distrib/libcommon.so.1.0.0
+ dosym libcommon.so.1.0.0 /usr/$(get_libdir)/libcommon.so.1
+ dosym libcommon.so.1 /usr/$(get_libdir)/libcommon.so
+
+ exeinto /usr/$(get_libdir)/meshlab/plugins
+ doexe distrib/plugins/*.so
+
+ insinto /usr/share/meshlab/shaders
+ doins -r distrib/shaders/*
+ newicon "${S}"/meshlab/images/eye64.png "${PN}".png
+ make_desktop_entry meshlab "Meshlab"
+}