summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo75@gmail.com>2018-03-24 21:20:52 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-29 14:34:55 +0200
commit74218d23a8e2b45a651dc9ecbac74c5dd6cd3607 (patch)
treeb4f597bf9017709e9de889621a3919ba9314b91e /media-gfx/rawtherapee
parentapp-crypt/cfssl: Remove old (diff)
downloadgentoo-74218d23a8e2b45a651dc9ecbac74c5dd6cd3607.tar.gz
gentoo-74218d23a8e2b45a651dc9ecbac74c5dd6cd3607.tar.bz2
gentoo-74218d23a8e2b45a651dc9ecbac74c5dd6cd3607.zip
media-gfx/rawtherapee: version bump to 5.4
Package-Manager: Portage-2.3.24, Repoman-2.3.6 .
Diffstat (limited to 'media-gfx/rawtherapee')
-rw-r--r--media-gfx/rawtherapee/Manifest1
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.4.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/Manifest b/media-gfx/rawtherapee/Manifest
index b4dd5dca02c1..dff37b91caec 100644
--- a/media-gfx/rawtherapee/Manifest
+++ b/media-gfx/rawtherapee/Manifest
@@ -1,3 +1,4 @@
DIST rawtherapee-5.1.tar.xz 10785516 BLAKE2B 5c8ae3f90c4ef4bc352b95761a5a2fd94e1541f6c7cec749c0985c95b85a7fd7cd5e96d439639513715b463c318d0f7b000cf48582b5391b944fc7a6ecaa3be8 SHA512 6a881fe24a4109c7db39cb8bee500eb2f9357c479ddb32b3c9b7987aa5d12e4f10083533b5657a0e0f0713fe4ebc58e0dcf204eb8d5c5b656f3e7867a775ab19
DIST rawtherapee-5.2.tar.xz 10819936 BLAKE2B 6f4474fdf86efe177861a1a4da2178f75c3589b9d5649d43f7b70a13e51c9658af74fbaea4528e5dc34287b8109cc30608028ca348eb2186d7a2452322139169 SHA512 ed2ff2e96ad4f0c50ebbc8a232d85b8c5b118bc956bc26aa72beb4741f464c46900aa668127fe7bdc963fabb5c2e2931c50cf784d1fc4fbc4dce3090412a1b5d
DIST rawtherapee-5.3.tar.xz 11042548 BLAKE2B 7e0697fc0c0e8b3078ccf1f9079a4adebf7c12e8e91e1d5499f304e93bda1d025540d3744b719535133f249941e2b4dcee98189d20e3009eceeb8531252bfd1a SHA512 8a9a7fe98ba0c8e03e964c809afc90afcc03a31b8b88e0f9e2ab4ecdc1fbe4712231f692d0585d95d638cae7171393e01860296149fc9dfbd86ecb35c3709284
+DIST rawtherapee-5.4.tar.xz 11991988 BLAKE2B 625b4e04b82f34d994e0f23f6aea6af4b0a2af2b6a325e916e7b51f8a83b568b65bef47a489be547d1e2437f9637b2ecea0d69d95bfabd53b61b11b46d9e36bc SHA512 6dc9a82202b80675f90eeb8f08c4484700561861f296546ae9425c6e9603f6e84bdc0859896c333d2367cc0b371c6bb6ab2fe36ff3d6f56419cbf18a58d8ef89
diff --git a/media-gfx/rawtherapee/rawtherapee-5.4.ebuild b/media-gfx/rawtherapee/rawtherapee-5.4.ebuild
new file mode 100644
index 000000000000..443bc8c4378f
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-5.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs flag-o-matic gnome2-utils xdg-utils
+
+MY_P=${P/_rc/-rc}
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="http://www.rawtherapee.com/"
+SRC_URI="http://rawtherapee.com/shared/source/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="openmp"
+
+RDEPEND="x11-libs/gtk+:3
+ dev-libs/expat
+ dev-libs/libsigc++:2
+ media-libs/libcanberra[gtk3]
+ media-libs/tiff:0
+ media-libs/libpng:0
+ media-libs/libiptcdata
+ media-libs/lcms:2
+ media-libs/lensfun
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ virtual/jpeg:0"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ dev-cpp/gtkmm:3.0"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_configure() {
+ # upstream tested that "fast-math" give wrong results, so filter it
+ # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+ filter-flags -ffast-math
+ # -Ofast enable "fast-math" both in gcc and clang
+ replace-flags -Ofast -O3
+ # In case we add an ebuild for klt we can (i)use that one,
+ # see http://cecas.clemson.edu/~stb/klt/
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ -DWITH_SYSTEM_KLT="off"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}