summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-06-29 09:00:03 +0200
committerJeroen Roovers <jer@gentoo.org>2020-06-29 09:02:13 +0200
commit07340c794c69a86d20f9b14d46f24b847923a813 (patch)
tree14bbb09d215ed2455bc5a3afd33aed44003204bb /media-gfx/scrot
parentapp-arch/dpkg: Version 1.20.2 (diff)
downloadgentoo-07340c794c69a86d20f9b14d46f24b847923a813.tar.gz
gentoo-07340c794c69a86d20f9b14d46f24b847923a813.tar.bz2
gentoo-07340c794c69a86d20f9b14d46f24b847923a813.zip
media-gfx/scrot: Update live ebuild
- Add libXcomposite - Remove libXcursor[0] [0] https://github.com/resurrecting-open-source-projects/scrot/pull/47 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'media-gfx/scrot')
-rw-r--r--media-gfx/scrot/files/scrot-9999-Xcursor.patch18
-rw-r--r--media-gfx/scrot/scrot-9999.ebuild5
2 files changed, 22 insertions, 1 deletions
diff --git a/media-gfx/scrot/files/scrot-9999-Xcursor.patch b/media-gfx/scrot/files/scrot-9999-Xcursor.patch
new file mode 100644
index 000000000000..dbb935219b35
--- /dev/null
+++ b/media-gfx/scrot/files/scrot-9999-Xcursor.patch
@@ -0,0 +1,18 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -34,4 +34,4 @@
+ bin_PROGRAMS = scrot
+ scrot_SOURCES = main.c getopt.c getopt1.c getopt.h scrot.h \
+ options.c options.h debug.h imlib.c structs.h note.c note.h
+-scrot_LDADD = -lX11 -lXfixes -lXcursor -lXcomposite @GIBLIB_LIBS@
++scrot_LDADD = -lX11 -lXfixes -lXcomposite @GIBLIB_LIBS@
+--- a/src/scrot.h
++++ b/src/scrot.h
+@@ -40,7 +40,6 @@
+ #include <X11/cursorfont.h>
+ #include <X11/extensions/Xfixes.h>
+ #include <X11/extensions/Xcomposite.h>
+-#include <X11/Xcursor/Xcursor.h>
+
+ #include <stdio.h>
+ #include <string.h>
diff --git a/media-gfx/scrot/scrot-9999.ebuild b/media-gfx/scrot/scrot-9999.ebuild
index a3ef577a9be9..82d865e83c56 100644
--- a/media-gfx/scrot/scrot-9999.ebuild
+++ b/media-gfx/scrot/scrot-9999.ebuild
@@ -15,7 +15,7 @@ KEYWORDS=""
RDEPEND="
>=media-libs/giblib-1.2.3
x11-libs/libX11
- x11-libs/libXcursor
+ x11-libs/libXcomposite
x11-libs/libXfixes
|| (
media-libs/imlib2[gif]
@@ -31,6 +31,9 @@ DEPEND="
DOCS=(
AUTHORS ChangeLog CONTRIBUTING.md README.md TODO
)
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-Xcursor.patch
+)
src_prepare() {
sed -i -e 's#-g -O3##g' src/Makefile.am || die