summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-12-06 20:23:17 -0300
committerPacho Ramos <pacho@gentoo.org>2023-12-18 11:19:12 +0100
commit2970c377a9bd61630b58b6ad7d3b1596b9bbf744 (patch)
tree525e105425ae2eb07214866ec4bb7c4b996d6bae /media-gfx/shotwell
parentsci-geosciences/gnome-maps: Version bump to 45.2 (diff)
downloadgentoo-2970c377a9bd61630b58b6ad7d3b1596b9bbf744.tar.gz
gentoo-2970c377a9bd61630b58b6ad7d3b1596b9bbf744.tar.bz2
gentoo-2970c377a9bd61630b58b6ad7d3b1596b9bbf744.zip
media-gfx/shotwell: Version bump to 0.32.4
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34154 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/Manifest1
-rw-r--r--media-gfx/shotwell/shotwell-0.32.4.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 400f7de0d6c0..d9c4e36c3006 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1,2 +1,3 @@
DIST shotwell-0.32.2.tar.xz 35327248 BLAKE2B e64c14fa8516dede11e5793f35328993755e83b893423f413a9419fe30fc8eebc26c61b34b259dcee1353dfdecb77f582c6e1a10a62e477032ea518d0e56af12 SHA512 3f502856ed0ad6dba18d696b67c940afe04b40130ba273bef8d2324301444c1c90e2762827061383785bb20f31b62a8657e9795b405f719254cec308f9430fca
DIST shotwell-0.32.3.tar.xz 35332112 BLAKE2B 8bd1e1ffffdeb4a78c6cc18192f53df50175d458c70a1847a492cec4448655be5be877f5b2c8d2574393f75a1a2bc7efa04c50d505b2a08250b886e42769dd84 SHA512 a8574402a71d8a5de70e3d045586cea325fad7291914cf11f0ce4ef9abf5868dd9e581a0a3f3929c16dbfd5d934ce24775a220169efab2099e2f594cdb229f86
+DIST shotwell-0.32.4.tar.xz 35335296 BLAKE2B 32be135643f165f32f315c332a4f0b34cd724285e7239eadbb250253b27ce97fb15d314f68a5392d88224a0b97f7f6ef8789c1f6c40051c26a25b9012e860b90 SHA512 516ab26d6620429175097886a1874d2eaf0513f6ef732bef5ee07ef8cd200028b34d98f4eb09b47a621f5313de42a5f415185d76853de478e0b5e0c4e89eea69
diff --git a/media-gfx/shotwell/shotwell-0.32.4.ebuild b/media-gfx/shotwell/shotwell-0.32.4.ebuild
new file mode 100644
index 000000000000..2e14de026137
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.32.4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson optfeature vala xdg
+
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~sparc ~x86"
+IUSE="opencv udev"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libgee-0.8.5:0.8=
+ >=net-libs/webkit-gtk-2.26:4.1
+ net-libs/libsoup:3.0
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libxml2-2.6.32:2
+ x11-libs/gdk-pixbuf:2
+ >=dev-db/sqlite-3.5.9:3
+ >=media-libs/gstreamer-1.20:1.0
+ >=media-libs/gst-plugins-base-1.20:1.0
+ >=media-libs/libgphoto2-2.5:=
+ udev? ( >=dev-libs/libgudev-145:= )
+ >=media-libs/gexiv2-0.12.3
+ >=media-libs/libraw-0.13.2:=
+ >=media-libs/libexif-0.6.16
+ app-crypt/libsecret
+ >=dev-libs/libportal-0.5:=[gtk]
+ media-libs/libwebp:=
+
+ >=app-crypt/gcr-3:0=[gtk]
+ x11-libs/cairo
+ opencv? ( >=media-libs/opencv-4.0.0:= )
+"
+RDEPEND="${DEPEND}
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ media-plugins/gst-plugins-meta:1.0
+"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-libs/glib
+ dev-util/gdbus-codegen
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ net-libs/libsoup:3.0[vala]
+ media-libs/gexiv2[vala]
+ app-crypt/gcr:0[vala]
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dunity_support=false
+ # -Dpublishers # In 0.30.2 all get compiled in anyways, even if restricted list, affects only runtime support
+ #trace
+ #measure
+ -Ddupe_detection=true
+ $(meson_use udev)
+ -Dinstall_apport_hook=false
+ $(meson_use opencv face_detection)
+ -Dfatal_warnings=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ optfeature "Enable support for the AVIF format" media-libs/libavif[gdk-pixbuf]
+ optfeature "Enable support for the HEIF format" media-libs/libheif[gdk-pixbuf]
+ optfeature "Enable support for the JPEG format" x11-libs/gdk-pixbuf[jpeg]
+ optfeature "Enable support for the TIFF format" x11-libs/gdk-pixbuf[tiff]
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}