summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-10-23 11:06:51 -0500
committerBen Kohler <bkohler@gentoo.org>2023-10-27 13:00:24 -0500
commit20ecdbf2a9919818447ffcfe80dd74fdd06084ab (patch)
tree501cf5d5b4c86bf127b5204e38a9d2d14c66e3c2 /media-gfx
parentapp-admin/mcelog: remove unused patch (diff)
downloadgentoo-20ecdbf2a9919818447ffcfe80dd74fdd06084ab.tar.gz
gentoo-20ecdbf2a9919818447ffcfe80dd74fdd06084ab.tar.bz2
gentoo-20ecdbf2a9919818447ffcfe80dd74fdd06084ab.zip
media-gfx/fotoxx: add 23.72
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fotoxx/Manifest1
-rw-r--r--media-gfx/fotoxx/fotoxx-23.72.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/Manifest b/media-gfx/fotoxx/Manifest
index fefbc6421dc9..036a24571022 100644
--- a/media-gfx/fotoxx/Manifest
+++ b/media-gfx/fotoxx/Manifest
@@ -2,3 +2,4 @@ DIST fotoxx-23.32-source.tar.gz 9273650 BLAKE2B 20d159e25ba280ff4f264da1a99f2af7
DIST fotoxx-23.50-source.tar.gz 9344552 BLAKE2B cb634e24b034bdb6e52bb2824fc549cfc1321516f4af8d8b34df4828122476fd46ca0234c6009616ad96a5d003818d403ef8ae6be115ac0a33db94e2eb8bd03e SHA512 629c7da961fcaff26916765a7b494b4596b8a9b62397901946c39c92bbc54694a2d3b9378a653f4144a191f74015e1067f0a414bfd4df00bc16982a922b52400
DIST fotoxx-23.60-source.tar.gz 9329991 BLAKE2B 92f86ae7abaff4df0687395364c2c498e6a5edfc83a491552fa73fd80f075580ab48127f36901e51ba46b3457ef728ab755646f62e46d33ff281619fc2bc2660 SHA512 fc8fca696edd3bdefd7fcb2f4866bc2380743a6500cc8a3f803f29b1bb25f9ed6e845cc63310de56563b877850aca036cfdca8754d2c4b038d84faf41a423e9a
DIST fotoxx-23.70-source.tar.gz 16130595 BLAKE2B d5cd0453c7cc568ddc5a8d66d5f79f4a907a52aa0d635cb32701a4293a210d703e05056a1140287d20434c636f5acffc869af135cf8a3f3762ca55e10e102a05 SHA512 3616f3e90e973c872b25607951ebd41f851df45b715cb3c2df982c1f74387d9cbf0ee5fc14f3de4ecb4e3251ba25affe6cd3b5e118bce31ff01c14637d588c5d
+DIST fotoxx-23.72-source.tar.gz 16130664 BLAKE2B 913b524314ee2cf81d9f18a2a03a983585bea033e2a177e16bc213539aa9b0e76bd2b68ccee25a11529836478d0469703c614123a4e0fe627c9dde69fbee7183 SHA512 1b1f94421002da719df8d3d61e481954a017461d7f442310fcac957e71c5cf8a9bb77566f9c9451a650cb772433527a3c102c49421f291a9126b8227a34d2cb8
diff --git a/media-gfx/fotoxx/fotoxx-23.72.ebuild b/media-gfx/fotoxx/fotoxx-23.72.ebuild
new file mode 100644
index 000000000000..6d3e66505952
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-23.72.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}-source.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libchamplain[gtk]
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-22.18-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ sed -i -e "/^Icon/ s/\.png$//" fotoxx.desktop || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC & AVIF file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}