summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-05-28 23:38:43 -0400
committerAlexis Ballier <aballier@gentoo.org>2017-06-23 07:35:34 +0200
commit0b9deda9488d7ea978a43f5cf3d49c4319468af6 (patch)
treef17802d0d29bea3cf7351bce2ab313661fae38cf /media-libs/avidemux-core
parentdev-python/pathlib2: keyword ~arm64 (diff)
downloadgentoo-0b9deda9488d7ea978a43f5cf3d49c4319468af6.tar.gz
gentoo-0b9deda9488d7ea978a43f5cf3d49c4319468af6.tar.bz2
gentoo-0b9deda9488d7ea978a43f5cf3d49c4319468af6.zip
media-libs/avidemux-core: Fix building with GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=594902 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-libs/avidemux-core')
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.6.8.ebuild3
-rw-r--r--media-libs/avidemux-core/files/avidemux-core-2.6.8-gcc6.patch50
2 files changed, 52 insertions, 1 deletions
diff --git a/media-libs/avidemux-core/avidemux-core-2.6.8.ebuild b/media-libs/avidemux-core/avidemux-core-2.6.8.ebuild
index 713066eac7f7..f7dde42a4753 100644
--- a/media-libs/avidemux-core/avidemux-core-2.6.8.ebuild
+++ b/media-libs/avidemux-core/avidemux-core-2.6.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -53,6 +53,7 @@ DEPEND="
S="${WORKDIR}/${MY_P}"
BUILD_DIR="${S}/buildCore"
+PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
DOCS=( AUTHORS README )
src_prepare() {
diff --git a/media-libs/avidemux-core/files/avidemux-core-2.6.8-gcc6.patch b/media-libs/avidemux-core/files/avidemux-core-2.6.8-gcc6.patch
new file mode 100644
index 000000000000..dbdf8ff93a8d
--- /dev/null
+++ b/media-libs/avidemux-core/files/avidemux-core-2.6.8-gcc6.patch
@@ -0,0 +1,50 @@
+--- a/avidemux_core/ADM_coreUtils/src/prefs.cpp
++++ b/avidemux_core/ADM_coreUtils/src/prefs.cpp
+@@ -44,8 +44,8 @@
+ const char *name2;
+ ADM_paramType type;
+ const char *defaultValue;
+- float min;
+- float max;
++ double min;
++ double max;
+ }optionDesc;
+
+ #include "prefs2_pref.h"
+--- a/avidemux_core/ADM_coreAudio/src/ADM_audioStreamBuffered.cpp
++++ b/avidemux_core/ADM_coreAudio/src/ADM_audioStreamBuffered.cpp
+@@ -46,7 +46,7 @@
+ // By construction, the error should be minimal
+ if(newDts!=ADM_AUDIO_NO_DTS)
+ {
+- if( abs(newDts-lastDts)>ADM_MAX_SKEW)
++ if( labs((int64_t)newDts-lastDts)>ADM_MAX_SKEW)
+ {
+ printf("[AudioStream] Warning skew in dts =%"PRId64", \n",(int64_t)newDts-(uint64_t)lastDts);
+ printf("[AudioStream] Warning skew lastDts=%s \n",ADM_us2plain(lastDts));
+--- a/avidemux_core/ADM_coreVideoCodec/src/ADM_ffmp43.cpp
++++ b/avidemux_core/ADM_coreVideoCodec/src/ADM_ffmp43.cpp
+@@ -30,19 +30,19 @@
+ #define WRAP_Open_Template(funcz,argz,display,codecid) \
+ {\
+ AVCodec *codec=funcz(argz);\
+-if(!codec) {GUI_Error_HIG("Codec",QT_TR_NOOP("Internal error finding codec"display));ADM_assert(0);} \
++if(!codec) {GUI_Error_HIG("Codec",QT_TR_NOOP("Internal error finding codec" display));ADM_assert(0);} \
+ codecId=codecid; \
+ _context->workaround_bugs=1*FF_BUG_AUTODETECT +0*FF_BUG_NO_PADDING; \
+ _context->error_concealment=3; \
+ if (avcodec_open(_context, codec) < 0) \
+ { \
+- printf("[lavc] Decoder init: "display" video decoder failed!\n"); \
+- GUI_Error_HIG("Codec","Internal error opening "display); \
++ printf("[lavc] Decoder init: " display " video decoder failed!\n"); \
++ GUI_Error_HIG("Codec","Internal error opening " display); \
+ ADM_assert(0); \
+ } \
+ else \
+ { \
+- printf("[lavc] Decoder init: "display" video decoder initialized! (%s)\n",codec->long_name); \
++ printf("[lavc] Decoder init: " display " video decoder initialized! (%s)\n",codec->long_name); \
+ } \
+ }
+