summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/emotion
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/emotion')
-rw-r--r--media-libs/emotion/Manifest3
-rw-r--r--media-libs/emotion/emotion-1.7.10.ebuild65
-rw-r--r--media-libs/emotion/emotion-1.7.8.ebuild56
-rw-r--r--media-libs/emotion/emotion-1.7.9.ebuild56
-rw-r--r--media-libs/emotion/emotion-9999.ebuild63
-rw-r--r--media-libs/emotion/files/respect-ldflags-with-gstreamer-backend.patch22
-rw-r--r--media-libs/emotion/metadata.xml8
7 files changed, 273 insertions, 0 deletions
diff --git a/media-libs/emotion/Manifest b/media-libs/emotion/Manifest
new file mode 100644
index 000000000000..7cd3a9c04df9
--- /dev/null
+++ b/media-libs/emotion/Manifest
@@ -0,0 +1,3 @@
+DIST emotion-1.7.10.tar.bz2 497860 SHA256 642f408580952ec37574c214d1315a518e48d2667cc004988813a5590412714c SHA512 9ac38d6b785ce3d3cc0f8b3bf712dfa2816a9a5452df434f81fce1645c7eb2d4739600433e4fd29890b4c1b2a5adb515f7234e757634a1d10ea7ff9819311895 WHIRLPOOL 29762874aafba1ef722ec1b131d31a851bd6cb910d698c6f87e3b9b94bc72287ef32c6aadb7ac27758d0224081ffa78f1f43729a9202f38e8a6487703400bf14
+DIST emotion-1.7.8.tar.bz2 497727 SHA256 de5f3962c9dd5616c886decf6fa9fa9dbec16fa7a7f61b83b98f252cb28fb56c SHA512 650f15cb656cbd97011c4690f67260646871fa788924128f6fb2798ca9c7734b4488572009decf538300dce0b7fb10bd0aba51d54c1c29844bb30b07a9b6b909 WHIRLPOOL c8a9e39137862131683ee147f620e1af80e2db7778859b45e1420b877ae5703ff2c7bd3e3ddafa587bc82cc6801cb0e3eb38cd0c3cc9d559cb4f17d5a04ead8f
+DIST emotion-1.7.9.tar.bz2 497737 SHA256 deaeb3ed147c5f057ea05a3caf3c89ee247cdff433149c7e3a7141269008cec9 SHA512 099864b1bba47d0c45db5fbfdce3b3e5c2a8fd43b690e4d362b7dbc539ee4ce9a01e527dc44950eb282164f85c85b11091b7652c01d5bede89aa263e0eeaa20c WHIRLPOOL c1108f17e559815d8f921e56c1dbfe14bf5e5c97aaeaa0ae8edeb0d2603b3d27d01dff39336cc3d15af15386e2cfffde690aaa65112a74096e102df0db1702d6
diff --git a/media-libs/emotion/emotion-1.7.10.ebuild b/media-libs/emotion/emotion-1.7.10.ebuild
new file mode 100644
index 000000000000..c8fb80f2570e
--- /dev/null
+++ b/media-libs/emotion/emotion-1.7.10.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="video libraries for e17"
+
+LICENSE="BSD-2"
+# The video deps (vlc/xine-lib/gstreamer) are a pain to keyword.
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gstreamer static-libs vlc xine"
+
+DEPEND=">=media-libs/evas-${PV}
+ >=media-libs/edje-${PV}
+ >=dev-libs/ecore-${PV}
+ >=dev-libs/eina-${PV}
+ >=dev-libs/eeze-${PV}
+ vlc? ( media-video/vlc )
+ xine? ( >=media-libs/xine-lib-1.1.1 )
+ !gstreamer? ( !vlc? ( !xine? ( >=media-libs/xine-lib-1.1.1 ) ) )
+ gstreamer? (
+ =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ =media-plugins/gst-plugins-ffmpeg-0.10*
+ )"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ if ! use vlc && ! use xine && ! use gstreamer ; then
+ E_ECONF+=(
+ --enable-xine
+ --disable-gstreamer
+ --disable-generic-vlc
+ )
+ else
+ E_ECONF+=(
+ $(use_enable xine)
+ $(use_enable gstreamer)
+ $(use_enable vlc generic-vlc)
+ )
+ fi
+
+ E_ECONF+=(
+ $(use_enable doc)
+ )
+
+ if use gstreamer ; then
+ addpredict "/root/.gconfd"
+ addpredict "/root/.gconf"
+ fi
+
+ enlightenment_src_configure
+}
diff --git a/media-libs/emotion/emotion-1.7.8.ebuild b/media-libs/emotion/emotion-1.7.8.ebuild
new file mode 100644
index 000000000000..1d4ccee17479
--- /dev/null
+++ b/media-libs/emotion/emotion-1.7.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit enlightenment
+
+DESCRIPTION="video libraries for e17"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer static-libs vlc xine"
+
+DEPEND=">=media-libs/evas-1.7.8
+ >=media-libs/edje-1.7.8
+ >=dev-libs/ecore-1.7.8
+ >=dev-libs/eina-1.7.8
+ >=dev-libs/eeze-1.7.4
+ vlc? ( media-video/vlc )
+ xine? ( >=media-libs/xine-lib-1.1.1 )
+ !gstreamer? ( !vlc? ( !xine? ( >=media-libs/xine-lib-1.1.1 ) ) )
+ gstreamer? (
+ =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ =media-plugins/gst-plugins-ffmpeg-0.10*
+ )"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ if ! use vlc && ! use xine && ! use gstreamer ; then
+ E_ECONF+=(
+ --enable-xine
+ --disable-gstreamer
+ --disable-generic-vlc
+ )
+ else
+ E_ECONF+=(
+ $(use_enable xine)
+ $(use_enable gstreamer)
+ $(use_enable vlc generic-vlc)
+ )
+ fi
+
+ E_ECONF+=(
+ $(use_enable doc)
+ )
+
+ if use gstreamer ; then
+ addpredict "/root/.gconfd"
+ addpredict "/root/.gconf"
+ fi
+
+ enlightenment_src_configure
+}
diff --git a/media-libs/emotion/emotion-1.7.9.ebuild b/media-libs/emotion/emotion-1.7.9.ebuild
new file mode 100644
index 000000000000..ea184031382b
--- /dev/null
+++ b/media-libs/emotion/emotion-1.7.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit enlightenment
+
+DESCRIPTION="video libraries for e17"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer static-libs vlc xine"
+
+DEPEND=">=media-libs/evas-1.7.9
+ >=media-libs/edje-1.7.9
+ >=dev-libs/ecore-1.7.9
+ >=dev-libs/eina-1.7.9
+ >=dev-libs/eeze-1.7.9
+ vlc? ( media-video/vlc )
+ xine? ( >=media-libs/xine-lib-1.1.1 )
+ !gstreamer? ( !vlc? ( !xine? ( >=media-libs/xine-lib-1.1.1 ) ) )
+ gstreamer? (
+ =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ =media-plugins/gst-plugins-ffmpeg-0.10*
+ )"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ if ! use vlc && ! use xine && ! use gstreamer ; then
+ E_ECONF+=(
+ --enable-xine
+ --disable-gstreamer
+ --disable-generic-vlc
+ )
+ else
+ E_ECONF+=(
+ $(use_enable xine)
+ $(use_enable gstreamer)
+ $(use_enable vlc generic-vlc)
+ )
+ fi
+
+ E_ECONF+=(
+ $(use_enable doc)
+ )
+
+ if use gstreamer ; then
+ addpredict "/root/.gconfd"
+ addpredict "/root/.gconf"
+ fi
+
+ enlightenment_src_configure
+}
diff --git a/media-libs/emotion/emotion-9999.ebuild b/media-libs/emotion/emotion-9999.ebuild
new file mode 100644
index 000000000000..9685e0c5c96d
--- /dev/null
+++ b/media-libs/emotion/emotion-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="video libraries for e17"
+
+LICENSE="BSD-2"
+IUSE="gstreamer static-libs vlc xine"
+
+DEPEND=">=media-libs/evas-${PV}
+ >=media-libs/edje-${PV}
+ >=dev-libs/ecore-${PV}
+ >=dev-libs/eina-${PV}
+ >=dev-libs/eeze-${PV}
+ vlc? ( media-video/vlc )
+ xine? ( >=media-libs/xine-lib-1.1.1 )
+ !gstreamer? ( !vlc? ( !xine? ( >=media-libs/xine-lib-1.1.1 ) ) )
+ gstreamer? (
+ =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ =media-plugins/gst-plugins-ffmpeg-0.10*
+ )"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ if ! use vlc && ! use xine && ! use gstreamer ; then
+ E_ECONF+=(
+ --enable-xine
+ --disable-gstreamer
+ --disable-generic-vlc
+ )
+ else
+ E_ECONF+=(
+ $(use_enable xine)
+ $(use_enable gstreamer)
+ $(use_enable vlc generic-vlc)
+ )
+ fi
+
+ E_ECONF+=(
+ $(use_enable doc)
+ )
+
+ if use gstreamer ; then
+ addpredict "/root/.gconfd"
+ addpredict "/root/.gconf"
+ fi
+
+ enlightenment_src_configure
+}
diff --git a/media-libs/emotion/files/respect-ldflags-with-gstreamer-backend.patch b/media-libs/emotion/files/respect-ldflags-with-gstreamer-backend.patch
new file mode 100644
index 000000000000..725b2788e259
--- /dev/null
+++ b/media-libs/emotion/files/respect-ldflags-with-gstreamer-backend.patch
@@ -0,0 +1,22 @@
+From 78870f848cc8c9440d35e84646a110a86404d3e9 Mon Sep 17 00:00:00 2001
+From: Tom Hacohen <tom@stosb.com>
+Date: Wed, 03 Apr 2013 16:44:57 +0000
+Subject: Fixed LDFLAGS usage when using the gstreamer backend.
+
+Reported by Tommy[D] on IRC.
+---
+diff --git a/configure.ac b/configure.ac
+index 0986b8a..324ea57 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -284,7 +284,7 @@ if test "x${enable_gstreamer}" = "xyes" ; then
+ AC_CHECK_LIB([gstinterfaces-0.10],
+ [gst_x_overlay_set_window_handle],
+ [AC_DEFINE([HAVE_X_OVERLAY_SET], [1], [Use gst_x_overlay_set_window_handle instead of old deprecated gst_x_overlay_set_xwindow_id])])
+- LDFLAGS=$sava_LDFLAGS
++ LDFLAGS=$save_LDFLAGS
+ fi
+ fi
+
+--
+cgit v0.9.1
diff --git a/media-libs/emotion/metadata.xml b/media-libs/emotion/metadata.xml
new file mode 100644
index 000000000000..282424f678d2
--- /dev/null
+++ b/media-libs/emotion/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>enlightenment</herd>
+<use>
+ <flag name='vlc'>Enable support for the <pkg>media-video/vlc</pkg> player backend</flag>
+</use>
+</pkgmetadata>