summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2022-05-01 19:56:12 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-02 08:45:42 +0200
commitf837ed3ce652c1ddb9e5ced54af6377f3a142f57 (patch)
tree50fac60a0835d9fa7677798e0be1a022c9dd5faa /media-libs/fcft
parentdev-python/python-pam: add missing deps (diff)
downloadgentoo-f837ed3ce652c1ddb9e5ced54af6377f3a142f57.tar.gz
gentoo-f837ed3ce652c1ddb9e5ced54af6377f3a142f57.tar.bz2
gentoo-f837ed3ce652c1ddb9e5ced54af6377f3a142f57.zip
media-libs/fcft: add 3.1.1
Signed-off-by: Arsen Arsenović <arsen@aarsen.me> Closes: https://github.com/gentoo/gentoo/pull/25278 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'media-libs/fcft')
-rw-r--r--media-libs/fcft/Manifest1
-rw-r--r--media-libs/fcft/fcft-3.1.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/media-libs/fcft/Manifest b/media-libs/fcft/Manifest
index 24f4c080f86f..66bc4c5c4128 100644
--- a/media-libs/fcft/Manifest
+++ b/media-libs/fcft/Manifest
@@ -1,2 +1,3 @@
DIST fcft-3.0.0.tar.gz 441458 BLAKE2B 9ff83691435953285f1b3f8b51dac7b17453a457eeb910f035e39c6fa3bb39098d3adbb7179f734261a4034e9ea8b034dd03a20ba0c364b7de2efe9b781dfdaa SHA512 fbf7ac7d777bdb530b90b79a0bd8b90d3f7ae8b099c2733304dbe89fbcc1a1a3493d1eac0478bcdee291d8c804da21461737fc3e34164637e86ff737023622b1
DIST fcft-3.0.1.tar.gz 441493 BLAKE2B 79fe864edf04b21fe88fa167e3390836e5c7254710082312068ff4c39624508e086f4eed2ea5706b52421b2276a6f2d1f2211ff0b256112d989764e667c44fe2 SHA512 856bec504a253678a2962c0a7c5029e5fd3d26e305ca3fcae8d9df398bcc84a03e9d67522673d1f1bb0ec91606c0627d6ab4bf2780cbb5965a01c91e6f0aac89
+DIST fcft-3.1.1.tar.gz 741229 BLAKE2B ef3fdca8f88893f0c69ed48181dce2a185d5e67ba6fc94d2f782b64f3078700c6be909560448f2625d43517f94aac2d82f58df29804b0fae5a72372a5b4a4004 SHA512 0344fc55906dee2588162f805ad703fe0efd26f3a8ce794273721d6111dd29bdb3589bd863f24998346018932f78b4c2dc04c4e2c8b49286db1efa9ecbc5521f
diff --git a/media-libs/fcft/fcft-3.1.1.ebuild b/media-libs/fcft/fcft-3.1.1.ebuild
new file mode 100644
index 000000000000..efecb5e0640c
--- /dev/null
+++ b/media-libs/fcft/fcft-3.1.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1
+
+DESCRIPTION="Simple library for font loading and glyph rasterization"
+HOMEPAGE="https://codeberg.org/dnkl/fcft"
+SRC_URI="https://codeberg.org/dnkl/fcft/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+# MIT for fcft
+# ZLIB for nanosvg
+LICENSE="MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="examples +harfbuzz +libutf8proc test"
+REQUIRED_USE="
+ libutf8proc? ( harfbuzz )
+ examples? ( libutf8proc )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/pixman
+ examples? (
+ dev-libs/libutf8proc:=
+ dev-libs/wayland
+ )
+ harfbuzz? (
+ media-libs/harfbuzz:=
+ )
+ libutf8proc? (
+ dev-libs/libutf8proc:=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ app-i18n/unicode-data
+ dev-libs/tllist
+ examples? (
+ dev-libs/wayland-protocols
+ )
+ test? (
+ dev-libs/check
+ harfbuzz? ( media-fonts/noto-emoji )
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/scdoc
+ examples? (
+ dev-util/wayland-scanner
+ )
+"
+
+src_prepare() {
+ default
+
+ rm -r unicode || die "Failed removing vendored unicode-data"
+
+ sed -i "s;unicode/UnicodeData.txt;${EPREFIX}/usr/share/unicode-data/UnicodeData.txt;" \
+ meson.build || die "Failed changing UnicodeData.txt to system's copy"
+ sed -i "s;unicode/emoji-data.txt;${EPREFIX}/usr/share/unicode-data/emoji/emoji-data.txt;" \
+ meson.build || die "Failed changing emoji-data.txt to system's copy"
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature harfbuzz grapheme-shaping)
+ $(meson_feature libutf8proc run-shaping)
+ $(meson_use examples)
+ $(use test && meson_use harfbuzz test-text-shaping)
+ # bundled, tiny, I believe this means we should always include it
+ -Dsvg-backend=nanosvg
+ -Ddocs=enabled
+ -Dwerror=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md )
+ meson_src_install
+
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+
+ use examples && newbin "${BUILD_DIR}/example/example" fcft-example
+}