summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-03 20:21:20 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-03 21:36:02 -0500
commit1626ef12c2e5839f4c7a31615f0d9f369cef2abd (patch)
tree218b9292f0b47303ac546f90f98b355d1b97c507 /media-libs/freeglut
parentgui-libs/display-manager-init: Drop old versions (diff)
downloadgentoo-1626ef12c2e5839f4c7a31615f0d9f369cef2abd.tar.gz
gentoo-1626ef12c2e5839f4c7a31615f0d9f369cef2abd.tar.bz2
gentoo-1626ef12c2e5839f4c7a31615f0d9f369cef2abd.zip
media-libs/freeglut: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/freeglut')
-rw-r--r--media-libs/freeglut/Manifest1
-rw-r--r--media-libs/freeglut/files/3.2.2-Fix-aliasing-violation.patch65
-rw-r--r--media-libs/freeglut/freeglut-3.2.2.ebuild48
3 files changed, 0 insertions, 114 deletions
diff --git a/media-libs/freeglut/Manifest b/media-libs/freeglut/Manifest
index 3054e52f37c8..246f763179ae 100644
--- a/media-libs/freeglut/Manifest
+++ b/media-libs/freeglut/Manifest
@@ -1,2 +1 @@
-DIST freeglut-3.2.2.tar.gz 397203 BLAKE2B e4151d9bd984504edb02fadf2983c750c1c81557f3467c01d4202d34e9e082a62f07d373908d3517f9b3fd3253b7b409f882cfe2187d4ff1787f3cdc09eecfe4 SHA512 190231951d314f854c244bd27f7c20488403bd0eecffc342097a2e3d1621cec87f6c209a77b4c153aabcf44697b4070227930e295ab74fb88953cbbf94fc81d9
DIST freeglut-3.4.0.tar.gz 413389 BLAKE2B 47b073c4e81473417358452ede3891b6fc36e324f66eec42fcbbadebb2144680e3b52caded504135239e170fd8f30a1fe8b6666a746b06d48cd7226c98a8114e SHA512 4bb6d6c086bac7a9c0ec78062dce58987555785abe6375f462ee249f65210a964a28fb10ba7ee8a42d7fafb00eb8d196eb403d65d255f02f88467369c187228b
diff --git a/media-libs/freeglut/files/3.2.2-Fix-aliasing-violation.patch b/media-libs/freeglut/files/3.2.2-Fix-aliasing-violation.patch
deleted file mode 100644
index d6544578bcf1..000000000000
--- a/media-libs/freeglut/files/3.2.2-Fix-aliasing-violation.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-https://bugs.gentoo.org/859847
-
-From 8c6f6bf3ad2fd33d15de6ee96175cd29bf804d9f Mon Sep 17 00:00:00 2001
-From: Matt Turner <mattst88@gmail.com>
-Date: Tue, 26 Jul 2022 15:47:02 -0400
-Subject: [PATCH] Fix aliasing violation
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Noticed when compiling with link-time optimizations.
-
-include/GL/freeglut_std.h:240:18: error: type of ‘glutBitmapHelvetica18’ does not match original declaration [-Werror=lto-type-mismatch]
- 240 | extern void* glutBitmapHelvetica18;
- | ^
-src/x11/fg_glutfont_definitions_x11.c:103:27: note: ‘glutBitmapHelvetica18’ was previously declared here
- 103 | struct freeglutBitmapFont glutBitmapHelvetica18 ;
- | ^
-src/x11/fg_glutfont_definitions_x11.c:103:27: note: code may be misoptimized unless ‘-fno-strict-aliasing’ is used
----
- src/x11/fg_glutfont_definitions_x11.c | 29 ++++++++++++++++++---------
- 1 file changed, 20 insertions(+), 9 deletions(-)
-
-diff --git a/src/x11/fg_glutfont_definitions_x11.c b/src/x11/fg_glutfont_definitions_x11.c
-index bec20371..d086a990 100644
---- a/src/x11/fg_glutfont_definitions_x11.c
-+++ b/src/x11/fg_glutfont_definitions_x11.c
-@@ -91,14 +91,25 @@ struct freeglutBitmapFont
- };
-
-
--struct freeglutStrokeFont glutStrokeRoman ;
--struct freeglutStrokeFont glutStrokeMonoRoman ;
-+static struct freeglutStrokeFont glutStrokeRoman_ ;
-+static struct freeglutStrokeFont glutStrokeMonoRoman_ ;
-
--struct freeglutBitmapFont glutBitmap9By15 ;
--struct freeglutBitmapFont glutBitmap8By13 ;
--struct freeglutBitmapFont glutBitmapTimesRoman10 ;
--struct freeglutBitmapFont glutBitmapTimesRoman24 ;
--struct freeglutBitmapFont glutBitmapHelvetica10 ;
--struct freeglutBitmapFont glutBitmapHelvetica12 ;
--struct freeglutBitmapFont glutBitmapHelvetica18 ;
-+static struct freeglutBitmapFont glutBitmap9By15_ ;
-+static struct freeglutBitmapFont glutBitmap8By13_ ;
-+static struct freeglutBitmapFont glutBitmapTimesRoman10_ ;
-+static struct freeglutBitmapFont glutBitmapTimesRoman24_ ;
-+static struct freeglutBitmapFont glutBitmapHelvetica10_ ;
-+static struct freeglutBitmapFont glutBitmapHelvetica12_ ;
-+static struct freeglutBitmapFont glutBitmapHelvetica18_ ;
-
-+
-+void *glutStrokeRoman = &glutStrokeRoman_ ;
-+void *glutStrokeMonoRoman = &glutStrokeMonoRoman_ ;
-+
-+void *glutBitmap9By15 = &glutBitmap9By15_ ;
-+void *glutBitmap8By13 = &glutBitmap8By13_ ;
-+void *glutBitmapTimesRoman10 = &glutBitmapTimesRoman10_ ;
-+void *glutBitmapTimesRoman24 = &glutBitmapTimesRoman24_ ;
-+void *glutBitmapHelvetica10 = &glutBitmapHelvetica10_ ;
-+void *glutBitmapHelvetica12 = &glutBitmapHelvetica12_ ;
-+void *glutBitmapHelvetica18 = &glutBitmapHelvetica18_ ;
---
-2.35.1
-
diff --git a/media-libs/freeglut/freeglut-3.2.2.ebuild b/media-libs/freeglut/freeglut-3.2.2.ebuild
deleted file mode 100644
index 43218afa4d37..000000000000
--- a/media-libs/freeglut/freeglut-3.2.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-multilib
-
-DESCRIPTION="A free OpenGL utility toolkit, the open-sourced alternative to the GLUT library"
-HOMEPAGE="http://freeglut.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="static-libs"
-
-# enabling GLES support seems to cause build failures
-RDEPEND=">=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
- >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
- >=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
- >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
- >=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}]"
-# gles? ( media-libs/mesa[egl(+),gles1,gles2,${MULTILIB_USEDEP}] )
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-Fix-aliasing-violation.patch
-)
-
-src_configure() {
- local mycmakeargs=(
-# "-DOpenGL_GL_PREFERENCE=GLVND" # bug 721006
- "-DFREEGLUT_GLES=OFF"
- "-DFREEGLUT_BUILD_DEMOS=OFF"
- "-DFREEGLUT_BUILD_STATIC_LIBS=$(usex static-libs ON OFF)"
- )
-# $(cmake-utils_use gles FREEGLUT_GLES)
- cmake-multilib_src_configure
-}
-
-multilib_src_install() {
- cmake_src_install
- cp "${ED}"/usr/$(get_libdir)/pkgconfig/{,free}glut.pc || die
-}