summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-22 18:33:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-22 19:02:24 +0100
commit86a95d88b08ae6a425ad44193483fad7e233198b (patch)
tree20396ade392143ce6f83f2d4d77ae14870fc1101 /media-libs/liblastfm
parentnet-analyzer/sslsplit: fix an error in network-sandboxed test (diff)
downloadgentoo-86a95d88b08ae6a425ad44193483fad7e233198b.tar.gz
gentoo-86a95d88b08ae6a425ad44193483fad7e233198b.tar.bz2
gentoo-86a95d88b08ae6a425ad44193483fad7e233198b.zip
media-libs/liblastfm: Add 1.1.0_pre20150206 version bump
Moved header dir to liblastfm5. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/liblastfm')
-rw-r--r--media-libs/liblastfm/Manifest1
-rw-r--r--media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/liblastfm/Manifest b/media-libs/liblastfm/Manifest
index 2dfb36c6b2f0..60f6dddc9af1 100644
--- a/media-libs/liblastfm/Manifest
+++ b/media-libs/liblastfm/Manifest
@@ -1 +1,2 @@
DIST liblastfm-1.0.9.tar.gz 119320 BLAKE2B 4c661b703af1e94b42d2bddffd994e0d33360979e47e0079f3824a9febcdba22c3ccedd8599da5c1d4b701a329cb4779bd680181837152cb1d23a231ec6eee73 SHA512 9d2bcf71b26d8a95920a07649c97b3faa071c49a8269268bb08fab01537392774873233d03cada09d3ce3fe2c45b0affdb74cd27c41f69342b973896effe1018
+DIST liblastfm-1.1.0_pre20150206.tar.gz 119380 BLAKE2B ec532b7577e60c02f9e8202b06e4e496b052801d60a27795d58204c6fbec62eea24512979ea9e42f643e7cfc01794982e07b808f6411b884893e13c29d9e17b0 SHA512 984d4b6b36a12e019e486425d243fc5be24fc3968b30f7ec746204c976b9c526477d56793205c9a6eed79bff1b33a2b1c7063d1d08fd376c4b89346337d8b166
diff --git a/media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild b/media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild
new file mode 100644
index 000000000000..07c936ffe144
--- /dev/null
+++ b/media-libs/liblastfm/liblastfm-1.1.0_pre20150206.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=44331654256df83bc1d3cbb271a8ce3d4c464686
+inherit cmake-utils vcs-snapshot
+
+DESCRIPTION="Collection of libraries to integrate Last.fm services"
+HOMEPAGE="https://github.com/lastfm/liblastfm"
+SRC_URI="https://github.com/lastfm/liblastfm/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0/0"
+IUSE="fingerprint test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtxml:5
+ fingerprint? (
+ dev-qt/qtsql:5
+ media-libs/libsamplerate
+ sci-libs/fftw:3.0
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+# 1 of 2 (UrlBuilderTest) is failing, last checked version 1.0.9
+RESTRICT="test"
+
+src_configure() {
+ # demos not working
+ local mycmakeargs=(
+ -DBUILD_DEMOS=OFF
+ -DBUILD_WITH_QT4=OFF
+ -DBUILD_FINGERPRINT=$(usex fingerprint)
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}