summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Udvare <audvare@gmail.com>2021-10-11 15:06:13 -0400
committerJames Le Cuirot <chewi@gentoo.org>2021-10-25 23:07:57 +0100
commita5b38687c0accc7a1bd5782da18c402bc683d0da (patch)
tree3a2b7394962ce0dea7b9db3cd42791f2f35fdbae /media-libs/libsdl2
parentdev-tcltk/tclperl: migrate to EAPI 7 (diff)
downloadgentoo-a5b38687c0accc7a1bd5782da18c402bc683d0da.tar.gz
gentoo-a5b38687c0accc7a1bd5782da18c402bc683d0da.tar.bz2
gentoo-a5b38687c0accc7a1bd5782da18c402bc683d0da.zip
media-libs/libsdl2: add USE flags hidapi, libusb
hidapi to enable/disable hidapi support (which was missing) libusb flag to enable libusb-based raw HID access on top of hidapi Package-Manager: Portage-3.0.28, Repoman-3.0.3 Closes: https://github.com/gentoo/gentoo/pull/22558 Signed-off-by: Andrew Udvare <audvare@gmail.com> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/libsdl2')
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.16.ebuild7
-rw-r--r--media-libs/libsdl2/metadata.xml2
2 files changed, 8 insertions, 1 deletions
diff --git a/media-libs/libsdl2/libsdl2-2.0.16.ebuild b/media-libs/libsdl2/libsdl2-2.0.16.ebuild
index e1bab222dedb..1d0b78dd975f 100644
--- a/media-libs/libsdl2/libsdl2-2.0.16.ebuild
+++ b/media-libs/libsdl2/libsdl2-2.0.16.ebuild
@@ -14,7 +14,7 @@ LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus doc fcitx4 gles1 gles2 haptic ibus jack +joystick kms libsamplerate nas opengl oss pipewire pulseaudio sndio +sound static-libs +threads udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
+IUSE="alsa aqua cpu_flags_ppc_altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 custom-cflags dbus doc fcitx4 gles1 gles2 haptic hidapi ibus jack +joystick kms libsamplerate libusb nas opengl oss pipewire pulseaudio sndio +sound static-libs +threads udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
REQUIRED_USE="
alsa? ( sound )
fcitx4? ( dbus )
@@ -23,6 +23,7 @@ REQUIRED_USE="
haptic? ( joystick )
ibus? ( dbus )
jack? ( sound )
+ libusb? ( hidapi )
nas? ( sound )
opengl? ( video )
pulseaudio? ( sound )
@@ -38,6 +39,7 @@ CDEPEND="
fcitx4? ( app-i18n/fcitx:4 )
gles1? ( media-libs/mesa[${MULTILIB_USEDEP},gles1] )
gles2? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
+ hidapi? ( dev-libs/hidapi[${MULTILIB_USEDEP}] )
ibus? ( app-i18n/ibus )
jack? ( virtual/jack[${MULTILIB_USEDEP}] )
kms? (
@@ -45,6 +47,7 @@ CDEPEND="
>=media-libs/mesa-9.0.0[${MULTILIB_USEDEP},gbm]
)
libsamplerate? ( media-libs/libsamplerate[${MULTILIB_USEDEP}] )
+ libusb? ( virtual/libusb:1[${MULTILIB_USEDEP}] )
nas? (
>=media-libs/nas-1.9.4[${MULTILIB_USEDEP}]
>=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
@@ -150,6 +153,8 @@ multilib_src_configure() {
$(use_enable alsa)
--disable-alsa-shared
$(use_enable jack)
+ $(use_enable hidapi)
+ $(use_enable libusb hidapi-libusb)
--disable-jack-shared
--disable-esd
$(use_enable pipewire)
diff --git a/media-libs/libsdl2/metadata.xml b/media-libs/libsdl2/metadata.xml
index d6b6433df9a4..b7129a681bd9 100644
--- a/media-libs/libsdl2/metadata.xml
+++ b/media-libs/libsdl2/metadata.xml
@@ -28,9 +28,11 @@
<flag name="gles1">include OpenGL ES 1.0 support</flag>
<flag name="gles2">include OpenGL ES 2.0 support</flag>
<flag name="haptic">Enable the haptic (force feedback) subsystem</flag>
+ <flag name="hidapi">Enable HID support via <pkg>dev-libs/hidapi</pkg></flag>
<flag name="ibus">Enable support for <pkg>app-i18n/ibus</pkg></flag>
<flag name="joystick">Control joystick support (disable at your own risk)</flag>
<flag name="kms">Build the KMSDRM video driver</flag>
+ <flag name="libusb">Enable raw HID access via <pkg>virtual/libusb</pkg></flag>
<flag name="sndio">Enable support for the <pkg>media-sound/sndio</pkg> backend</flag>
<flag name="pipewire">Enable support for the <pkg>media-video/pipewire</pkg> audio backend</flag>
<flag name="sound">Control audio support (disable at your own risk)</flag>