summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-09-24 19:24:04 +0200
committerMatt Turner <mattst88@gentoo.org>2022-09-27 20:30:40 -0400
commit0cf5e94dbab424b05dc7934a484d4ec60c17de80 (patch)
tree32494671a4b6e5cf4c3948156adce50d351cc134 /media-libs/libshumate
parentnet-libs/rest: Version bump to 0.9.1 (diff)
downloadgentoo-0cf5e94dbab424b05dc7934a484d4ec60c17de80.tar.gz
gentoo-0cf5e94dbab424b05dc7934a484d4ec60c17de80.tar.bz2
gentoo-0cf5e94dbab424b05dc7934a484d4ec60c17de80.zip
media-libs/libshumate: Add new package, version 1.0.1
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/libshumate')
-rw-r--r--media-libs/libshumate/Manifest1
-rw-r--r--media-libs/libshumate/libshumate-1.0.1.ebuild60
-rw-r--r--media-libs/libshumate/metadata.xml8
3 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/libshumate/Manifest b/media-libs/libshumate/Manifest
new file mode 100644
index 000000000000..6cafb6c5c7dd
--- /dev/null
+++ b/media-libs/libshumate/Manifest
@@ -0,0 +1 @@
+DIST libshumate-1.0.1.tar.xz 109884 BLAKE2B b1a4838b3f43df00ded7973e78acaceaa1c2fa6bb3a67214e475026a980c03f610e68b8d2a992093f091731e8d8e48e954d1ba917e93071f63a984f45a3142bc SHA512 19bf8a563d9b5c9cca3adfc337ec8843c7d8b891fcdd789adecfb79a46c3ba6f674795d39199ce154c5a3f6b95eac5d6e56ba73066f2ab18c8a95d3646b9ad25
diff --git a/media-libs/libshumate/libshumate-1.0.1.ebuild b/media-libs/libshumate/libshumate-1.0.1.ebuild
new file mode 100644
index 000000000000..e3f5bb4d13fb
--- /dev/null
+++ b/media-libs/libshumate/libshumate-1.0.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala virtualx
+
+DESCRIPTION="Shumate is a GTK toolkit providing widgets for embedded maps"
+HOMEPAGE="https://wiki.gnome.org/Projects/libshumate https://gitlab.gnome.org/GNOME/libshumate"
+
+SLOT="1.0/1"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+IUSE="gtk-doc +introspection vala" # vector-renderer is still experimental, maybe put in at a later release
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=x11-libs/cairo-1.4
+ >=dev-db/sqlite-1.12:3
+ >=gui-libs/gtk-4:4
+ >=net-libs/libsoup-3.0:3.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3:= )
+"
+# vector-renderer? (
+# >=dev-libs/json-glib-1.6.0[introspection?]
+# dev-libs/protobuf-c
+# )
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection gir)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ -Ddemos=false # only built, not installed
+ # $(meson_use vector-renderer vector_renderer)
+ -Dvector_renderer=false
+ -Dlibsoup3=true
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/libshumate-1.0 "${ED}"/usr/share/gtk-doc/libshumate-1.0 || die
+ fi
+}
diff --git a/media-libs/libshumate/metadata.xml b/media-libs/libshumate/metadata.xml
new file mode 100644
index 000000000000..f453528b934f
--- /dev/null
+++ b/media-libs/libshumate/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>