summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-10-22 11:02:47 -0300
committerMatt Turner <mattst88@gentoo.org>2022-10-25 11:25:04 -0400
commit4cd9e44db67fe9ca03a5efc7f2d19779cbe7205d (patch)
treebad9598dd88f18b6a05ef8890a56e0886546d809 /media-libs/libshumate
parentsci-geosciences/gnome-maps: Version bump to 43.1 (diff)
downloadgentoo-4cd9e44db67fe9ca03a5efc7f2d19779cbe7205d.tar.gz
gentoo-4cd9e44db67fe9ca03a5efc7f2d19779cbe7205d.tar.bz2
gentoo-4cd9e44db67fe9ca03a5efc7f2d19779cbe7205d.zip
media-libs/libshumate: Version bump to 1.0.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/27901 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/libshumate')
-rw-r--r--media-libs/libshumate/Manifest1
-rw-r--r--media-libs/libshumate/libshumate-1.0.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/libshumate/Manifest b/media-libs/libshumate/Manifest
index 6cafb6c5c7dd..d4e18b233f37 100644
--- a/media-libs/libshumate/Manifest
+++ b/media-libs/libshumate/Manifest
@@ -1 +1,2 @@
DIST libshumate-1.0.1.tar.xz 109884 BLAKE2B b1a4838b3f43df00ded7973e78acaceaa1c2fa6bb3a67214e475026a980c03f610e68b8d2a992093f091731e8d8e48e954d1ba917e93071f63a984f45a3142bc SHA512 19bf8a563d9b5c9cca3adfc337ec8843c7d8b891fcdd789adecfb79a46c3ba6f674795d39199ce154c5a3f6b95eac5d6e56ba73066f2ab18c8a95d3646b9ad25
+DIST libshumate-1.0.2.tar.xz 110656 BLAKE2B 75abbfd9b4e1e7eb1044a33ff1b46391024005487f01aa4401552727322f92f28120104af4c2f90bb91c70ada6282882b9ee7f50ac62542aab8c88cc227799f8 SHA512 15539ce50462b345e4329fc27f52a5d1fb143e82821a990ce818a576fec94d1fe1fbef9926d0251d169f22394f3f21c62e56fe4d97bbdd4482429c70f22c6b2d
diff --git a/media-libs/libshumate/libshumate-1.0.2.ebuild b/media-libs/libshumate/libshumate-1.0.2.ebuild
new file mode 100644
index 000000000000..e3f5bb4d13fb
--- /dev/null
+++ b/media-libs/libshumate/libshumate-1.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala virtualx
+
+DESCRIPTION="Shumate is a GTK toolkit providing widgets for embedded maps"
+HOMEPAGE="https://wiki.gnome.org/Projects/libshumate https://gitlab.gnome.org/GNOME/libshumate"
+
+SLOT="1.0/1"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+IUSE="gtk-doc +introspection vala" # vector-renderer is still experimental, maybe put in at a later release
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=x11-libs/cairo-1.4
+ >=dev-db/sqlite-1.12:3
+ >=gui-libs/gtk-4:4
+ >=net-libs/libsoup-3.0:3.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3:= )
+"
+# vector-renderer? (
+# >=dev-libs/json-glib-1.6.0[introspection?]
+# dev-libs/protobuf-c
+# )
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1 )
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection gir)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ -Ddemos=false # only built, not installed
+ # $(meson_use vector-renderer vector_renderer)
+ -Dvector_renderer=false
+ -Dlibsoup3=true
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/libshumate-1.0 "${ED}"/usr/share/gtk-doc/libshumate-1.0 || die
+ fi
+}