summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-05-16 13:29:42 -0700
committerSam James <sam@gentoo.org>2022-05-16 23:30:29 +0000
commitc73aabb310313383d209f1d0ec8296fc77db8549 (patch)
tree563d801a7bd0307e36a8f01bbdaecead40e2fba3 /media-libs/libuninameslist/libuninameslist-20211114.ebuild
parentdev-php/pecl-memcached: prefer dev-libs/libmemcached-awesome (diff)
downloadgentoo-c73aabb310313383d209f1d0ec8296fc77db8549.tar.gz
gentoo-c73aabb310313383d209f1d0ec8296fc77db8549.tar.bz2
gentoo-c73aabb310313383d209f1d0ec8296fc77db8549.zip
media-libs/libuninameslist: Add 20211114
The patch fixes undefined references with slibtool when libuninameslist is not already installed where it links with the installed package rather than the newly compiled library. The other bug was already fixed in upstream before the latest release. Bug: https://bugs.gentoo.org/792474 Upstream-PR: https://github.com/fontforge/libuninameslist/pull/27 Upstream-Commit: https://github.com/fontforge/libuninameslist/commit/77f4eea51b87c2e7a36cd3e1e64b424cdd5f7ad8 Bug: https://bugs.gentoo.org/779670 Upstream-PR: https://github.com/fontforge/libuninameslist/pull/24 Upstream-Commit: https://github.com/fontforge/libuninameslist/commit/9192c8dfee8c9e437e841962fec78cba1093d0d6 Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libuninameslist/libuninameslist-20211114.ebuild')
-rw-r--r--media-libs/libuninameslist/libuninameslist-20211114.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/libuninameslist/libuninameslist-20211114.ebuild b/media-libs/libuninameslist/libuninameslist-20211114.ebuild
new file mode 100644
index 000000000000..d237b6cedd16
--- /dev/null
+++ b/media-libs/libuninameslist/libuninameslist-20211114.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library of unicode annotation data"
+HOMEPAGE="https://github.com/fontforge/libuninameslist"
+SRC_URI="https://github.com/fontforge/libuninameslist/releases/download/${PV}/${PN}-dist-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+PATCHES=(
+ "${FILESDIR}/${P}-slibtool.patch" # 792474
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static --enable-frenchlib
+}
+
+src_install() {
+ default
+ find "${ED}"/usr -name '*.la' -delete || die
+}